Tests don't run when a module that dne is required (fennec)

RESOLVED FIXED

Status

Add-on SDK
General
P1
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: erikvold, Assigned: jsantell)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

when I require('xyz'); in my tests, then no tests are run, and no error message is displayed even with the -v option.

Expected:

An error message.
OS: All → Android

Updated

6 years ago
Priority: -- → P1
This seems to be erroring for me now -- Erik, can you confirm?
Flags: needinfo?(evold)
We should have a test for this.
Flags: needinfo?(evold)
(Assignee)

Updated

5 years ago
Assignee: nobody → jsantell
Created attachment 793065 [details]
GH PR 1213

Added tests for this use case, passes in both FF/Fennec -- also switched to new test format
Attachment #793065 - Flags: review?(evold)
Reimplemented the stacktrace tests for this, all passing
Flags: needinfo?(evold)
Comment on attachment 793065 [details]
GH PR 1213

Nice!
Attachment #793065 - Flags: review?(evold) → review+
Flags: needinfo?(evold)

Comment 6

5 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/4771061cd6a123c887b3ba6fe10f661df67b88e8
Bug 782824 tests for modules that do not exist

https://github.com/mozilla/addon-sdk/commit/43fc24f6884b862acd2e9bf2334054310d4df74e
Merge pull request #1213 from jsantell/782824-tests-for-dne-modules

Fix Bug 782824 tests for modules that do not exist, r=@erikvold

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.