Open Bug 782838 Opened 12 years ago Updated 1 year ago

Opening link with Middle click opens more than one tab (two tabs)

Categories

(Firefox :: Tabbed Browser, defect)

17 Branch
x86
Windows 7
defect

Tracking

()

UNCONFIRMED

People

(Reporter: mdaskalo, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120813030532

Steps to reproduce:

I did a bug search (https://bugzilla.mozilla.org/buglist.cgi?quicksearch=middle%20click;list_id=4036229) . Then middle clicked on bug 702750 .

I didn't notice this in build from aug 10th.
other similar issues (by description) seem to be registered, bust most of them seem to be obsolete.


Actual results:

Two new tabs with URL https://bugzilla.mozilla.org/show_bug.cgi?id=702750 were opened in the window


Expected results:

Only one new tab with URL https://bugzilla.mozilla.org/show_bug.cgi?id=702750 should be opened.
The problems is not always reproduced. Before filing the bug i tried several times this, and all the times when I middle clicked the bug number i received two new tabs.

Right after the filing of the bug I decided to test it again.

I clicked on one of the URL in bug description - and surprisingly I received only one new tab.

I went on page with the bug list (I didn't close it). Middle clicked on the same bug number, and received only one new tab.

So it seems there is some condition which is triggering the problem.
After submitting the new comment in bugzilla, I middle-clicked on the 'XML' link in bugzilla - and it showed 2 tabs.

So it seems to happen mostly with links that have not been visited.
WFM on:
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0 (20120820030522)

Mihail, can you please try to reproduce this issue in safe mode? http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Component: Untriaged → Tabbed Browser
I had the same issue with FF14 and now with FF15, windows 7 x64. Disabling add-ons and loading firefox in safe mode didn't help. Other software worked just fine, there was no unexpected behavior in chrome. I tried middle-clicking in my mouse programming software, and it registered every click properly (i.e. once).

However, when I plugged in another mouse middle-clicking a link worked properly in FF with both mice. I suspect the problem was caused by mouse driver, considering this issue hasn't been reported 9001 time it just had to be something external to firefox. So I downloaded and reinstalled mouse driver (not sure if it's a new version), everything seems fine so far. The mouse is cyborg RAT 7 contagion.

This is strange, however, that of all things only firefox registered multiple middle clicks.
Taking my words back. Updating the driver didn't solve the problem. it's just this behavior is sort of erratic. Sometimes links open in two tabs sometimes they don't, but they mostly do. I'm not sure of the conditions to reproduce the issue. I was also able to reproduce unexpected behavior on my RAT 7 with another mouse plugged in, but not on the another mouse itself (logitech m305). So it still seems to be a mouse issue.
Too bad I cant edit my comments, too much misinformation in previous one.
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.