Mac OS X builds of fr locale fail to start due to 'XPCOMGlueLoad error 4:0 for file ... Contents/MacOS/libxpcom.dylib'

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
critical
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({regression})

17 Branch
All
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox16 unaffected, firefox17- affected)

Details

(Whiteboard: [mozmill-test-failure])

(Reporter)

Description

6 years ago
In our yesterdays Mozmill testruns we have detected that localized nightly builds for mozilla-central at least for the fr locale are broken and can't be started. The failure we are seeing and which I can reproduce is:

XPCOMGlueLoad error 4:0 for file /var/folders/wd/zmy4z7xn7wd7sjq90z1y52f80000gn/T/tmpyPSsTp.binary/FirefoxNightly.app/Contents/MacOS/libxpcom.dylib:
BIND_OPCODE_SET_SEGMENT_AND_OFFSET_ULEB has segment 4 which is too large (3)
 in /var/folders/wd/zmy4z7xn7wd7sjq90z1y52f80000gn/T/tmpyPSsTp.binary/FirefoxNightly.app/Contents/MacOS/XUL
Couldn't load XPCOM.

I will check if other locales are affected and which changeset could have been caused that.
(Reporter)

Comment 1

6 years ago
Regressed between the builds 2012-08-13-03-05-32-mozilla-central-firefox-17.0a1.fr.mac.dmg and 2012-08-14-03-05-21-mozilla-central-firefox-17.0a1.fr.mac.dmg. I'm not able to reproduce with the de locale. So not all or only fr is affected.

Pass: f89feda9d997
Fail: 22288130fea2

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f89feda9d997&tochange=22288130fea2
Version: 14 Branch → 17 Branch
(Reporter)

Comment 2

6 years ago
Looks like the latest tinderbox build from the following location at least works. Has something been fixed since yesterday?

http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-l10n/
(Reporter)

Comment 3

6 years ago
Todays fr builds (20120814030521) on all OS X versions are still broken.
(Reporter)

Comment 4

6 years ago
That was my mistake. As the build id shows it were yesterdays builds. Builds with the id 20120815030556 work fine now.

If anyone knows what happened please add the causing bug to the dependency list. For now I will close this bug as WFM.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
tracking-firefox17: ? → -
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.