Last Comment Bug 782981 - crash in nsObjectFrame::BeginSwapDocShells
: crash in nsObjectFrame::BeginSwapDocShells
Status: RESOLVED FIXED
[native-crash]
: crash, regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 17 Branch
: All All
: -- critical (vote)
: mozilla17
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
: 782979 783000 783004 783074 783365 783655 (view as bug list)
Depends on:
Blocks: 775965
  Show dependency treegraph
 
Reported: 2012-08-15 08:52 PDT by Gian-Carlo Pascutto [:gcp]
Modified: 2012-08-17 14:02 PDT (History)
27 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments

Description Gian-Carlo Pascutto [:gcp] 2012-08-15 08:52:52 PDT
This bug was filed from the Socorro interface and is 
report bp-60d55399-4783-464b-848e-032772120815 .
============================================================= 

Visit http://stara.fi. Close tab. (Repeat a few times if needed). Nightly crashes.
Comment 1 Gian-Carlo Pascutto [:gcp] 2012-08-15 08:54:59 PDT
Most likely a dupe of bug 782979 with different STR.
Comment 2 Logan Rosen [:Logan] 2012-08-15 09:15:19 PDT
*** Bug 782979 has been marked as a duplicate of this bug. ***
Comment 3 Logan Rosen [:Logan] 2012-08-15 09:18:15 PDT
This is also happening when closing the Gmail tab in the latest nightly build, as you can see in the duplicate bug. Definitely a critical issue.
Comment 4 Alice0775 White 2012-08-15 09:23:57 PDT
I can reproduce the crash on windows7,
bp-0eeabe52-0217-4e48-9d25-5a38a2120815

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/22288130fea2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813211942
Crash:
http://hg.mozilla.org/mozilla-central/rev/d9183f015df8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120814055342
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=22288130fea2&tochange=d9183f015df8



Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/303b75594832
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813210542
Crash:
http://hg.mozilla.org/integration/mozilla-inbound/rev/4ddd9c731adc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813210943
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=303b75594832&tochange=4ddd9c731adc


Suspected: Bug 775965
Comment 5 Logan Rosen [:Logan] 2012-08-15 09:27:01 PDT
Yep, looks like the patch for Bug 775965 is causing this crash. I subscribed Chris, who authored the patch and pushed it to m-i.
Comment 6 Octoploid 2012-08-15 09:31:48 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/bcac58cbf328 is the cause of this issue.
Reverting the commit "solves" the problem.
Comment 7 Mike Beltzner [:beltzner, not reading bugmail] 2012-08-15 10:01:50 PDT
Noming, as nightly has become fairly unusable. I have a window full of tabs I can't close without crashing the browser :)
Comment 8 Mike Beltzner [:beltzner, not reading bugmail] 2012-08-15 10:05:59 PDT
*** Bug 783000 has been marked as a duplicate of this bug. ***
Comment 9 Ed Morley [:emorley] 2012-08-15 10:11:05 PDT
Backing out now & will respin.
Comment 10 Ed Morley [:emorley] 2012-08-15 10:12:52 PDT
Should be fixed by the backout:
https://hg.mozilla.org/mozilla-central/rev/7d4268f8884c

Nightly has been respun
Comment 11 Ed Morley [:emorley] 2012-08-15 10:13:42 PDT
> Nightly has been respun

ETA 3-5 hours, depending on platform.
Comment 12 Ed Lee :Mardak 2012-08-15 11:34:10 PDT
Nightly (Mac) found an update at 11:30am and closing Gmail stopped crashing.

before: Built from http://hg.mozilla.org/mozilla-central/rev/86ee4deea55b
after: Built from http://hg.mozilla.org/mozilla-central/rev/7d4268f8884c
Comment 13 Scoobidiver (away) 2012-08-15 11:35:13 PDT
*** Bug 783004 has been marked as a duplicate of this bug. ***
Comment 14 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-08-15 12:32:31 PDT
Got this while closing tab on http://www.tennis-x.com/xblog/2012-08-14/10461.php
Comment 15 Semtex 2012-08-15 12:53:45 PDT
Got this few minutes ago https://crash-stats.mozilla.com/report/index/bp-ad54b876-536f-4344-b957-56a022120815 while closing Gmail tab. Nightly l10n. Did there was respin for l10n as well?
Comment 16 Ed Morley [:emorley] 2012-08-15 13:05:59 PDT
(In reply to semtex2 from comment #15)
> Got this few minutes ago
> https://crash-stats.mozilla.com/report/index/bp-ad54b876-536f-4344-b957-
> 56a022120815 while closing Gmail tab. Nightly l10n. Did there was respin for
> l10n as well?

(In reply to Ed Morley [:edmorley] from comment #11)
> > Nightly has been respun
> 
> ETA 3-5 hours, depending on platform.
Comment 17 Scoobidiver (away) 2012-08-16 01:21:33 PDT
*** Bug 783074 has been marked as a duplicate of this bug. ***
Comment 18 Semtex 2012-08-16 10:59:12 PDT
So, no respin for Win32 l10n Nightly, also no new build, something went not OK IMO.
Comment 19 Scoobidiver (away) 2012-08-16 14:16:42 PDT
*** Bug 783365 has been marked as a duplicate of this bug. ***
Comment 20 Scoobidiver (away) 2012-08-17 14:02:47 PDT
*** Bug 783655 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.