Closed Bug 783144 Opened 9 years ago Closed 6 years ago

contents of <option> in dropdown are painted as selected text

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox14 --- affected
firefox15 --- affected
firefox16 --- affected
firefox17 --- affected
firefox-esr10 --- unaffected

People

(Reporter: masayuki, Unassigned)

References

Details

(Keywords: regression)

1. Go to https://bugzilla.mozilla.org/query.cgi?format=specific
2. mouse down on "Product" which is left label of product <select>
3. mouse up on "Words" which is beflow the "Product" label.
4. Open the <select>'s dropdown by click it.

Then, the text in <option> elements are painted as selected. I can reproduce this bug at least on Fx14, but not so on ESR10.

The text in <option> elements shouldn't be painted as selected.
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c7101dec8deb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111220 Firefox/11.0a1 ID:20111220083550
Bad:
http://hg.mozilla.org/mozilla-central/rev/a8506ab2c654
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111220 Firefox/11.0a1 ID:20111220085450
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c7101dec8deb&tochange=a8506ab2c654


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/feaccb6a4c35
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111219 Firefox/11.0a1 ID:20111219235256
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/0aa9c3a5b7e1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111219 Firefox/11.0a1 ID:20111220011653
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=feaccb6a4c35&tochange=0aa9c3a5b7e1

Suspected: Bug 619273
Blocks: 619273
Thank you, Alice-san!

Maybe, fix for bug 739396 would fix this bug too.
OS: Windows 7 → All
Hardware: x86_64 → All
Duplicate of this bug: 798962
I cannot reproduce this bug anymore. Fixed by bug 739396?

-> WFM
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.