B2G startup crashes in nsWebShellWindow::WindowResized

RESOLVED DUPLICATE of bug 783134

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 783134
6 years ago
6 years ago

People

(Reporter: kanru, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
#0  0x424d725e in mozalloc_abort (
    msg=0xbe9457b0 "###!!! ABORT: You can't dereference a NULL nsCOMPtr with operator->().: 'mRawPtr != 0', file ../../dist/include/nsCOMPtr.h, line 781") at /home/kanru/zone2/mozilla/central/memory/mozalloc/mozalloc_abort.cpp:23
#1  0x41b5f222 in Abort (
    aMsg=0xbe9457b0 "###!!! ABORT: You can't dereference a NULL nsCOMPtr with operator->().: 'mRawPtr != 0', file ../../dist/include/nsCOMPtr.h, line 781") at /home/kanru/zone2/mozilla/central/xpcom/base/nsDebugImpl.cpp:423
#2  0x41b5f0dc in NS_DebugBreak_P (aSeverity=3, 
    aStr=0x42661fc8 "You can't dereference a NULL nsCOMPtr with operator->().", aExpr=0x42662004 "mRawPtr != 0", 
    aFile=0x42662014 "../../dist/include/nsCOMPtr.h", aLine=781)
    at /home/kanru/zone2/mozilla/central/xpcom/base/nsDebugImpl.cpp:380
#3  0x40968286 in nsCOMPtr<nsIViewManager>::operator-> (this=0xbe945bf4) at ../../dist/include/nsCOMPtr.h:781
#4  0x415ec3f4 in nsWebShellWindow::WindowResized (this=0x1f13410, aWidget=0x1f082a0, aWidth=320, aHeight=480)
    at /home/kanru/zone2/mozilla/central/xpfe/appshell/src/nsWebShellWindow.cpp:255
#5  0x417d78ae in nsWindow::Resize (this=0x1f082a0, aX=0, aY=0, aWidth=320, aHeight=480, aRepaint=false)
    at /home/kanru/zone2/mozilla/central/widget/gonk/nsWindow.cpp:399
#6  0x417d7680 in nsWindow::Create (this=0x1f082a0, aParent=0x0, aNativeParent=0x0, aRect=..., aContext=0x0, 
    aInitData=0xbe945e64) at /home/kanru/zone2/mozilla/central/widget/gonk/nsWindow.cpp:317
#7  0x415ebc12 in nsWebShellWindow::Initialize (this=0x1f13410, aParent=0x0, aOpener=0x0, aUrl=0x0, 
    aInitialWidth=1, aInitialHeight=1, aIsHiddenWindow=false, widgetInitData=...)
    at /home/kanru/zone2/mozilla/central/xpfe/appshell/src/nsWebShellWindow.cpp:168
#8  0x415e952e in nsAppShellService::JustCreateTopWindow (this=0x1cfc728, aParent=0x0, aUrl=0x0, 
    aChromeMask=2147487742, aInitialWidth=1, aInitialHeight=1, aIsHiddenWindow=false, aResult=0xbe945ee0)
    at /home/kanru/zone2/mozilla/central/xpfe/appshell/src/nsAppShellService.cpp:350
#9  0x415e9120 in nsAppShellService::CreateTopLevelWindow (this=0x1cfc728, aParent=0x0, aUrl=0x0, 
    aChromeMask=2147487742, aInitialWidth=-1, aInitialHeight=-1, aResult=0xbe945f28)
    at /home/kanru/zone2/mozilla/central/xpfe/appshell/src/nsAppShellService.cpp:145
#10 0x415ffb1a in nsAppStartup::CreateChromeWindow2 (this=0x1921d18, aParent=0x0, aChromeFlags=2147487742, 
    aContextFlags=0, aURI=0x1f13318, aCancel=0xbe94617b, _retval=0xbe946184)
    at /home/kanru/zone2/mozilla/central/toolkit/components/startup/nsAppStartup.cpp:687
#11 0x415a346a in nsWindowWatcher::OpenWindowInternal (this=0x1921db8, aParent=0x0, 
    aUrl=0x1f13258 "chrome://browser/content/shell.xul", aName=0x1f13280 "_blank", 
    aFeatures=0x1f13290 "chrome,dialog=no,all", aCalledFromJS=false, aDialog=true, aNavigate=true, argv=0x1f132c8, 
    _retval=0xbe946490)
    at /home/kanru/zone2/mozilla/central/embedding/components/windowwatcher/src/nsWindowWatcher.cpp:717
#12 0x415a257a in nsWindowWatcher::OpenWindow (this=0x1921db8, aParent=0x0, 
    aUrl=0x1f13258 "chrome://browser/content/shell.xul", aName=0x1f13280 "_blank", 
    aFeatures=0x1f13290 "chrome,dialog=no,all", aArguments=0x1d038a0, _retval=0xbe946490)
    at /home/kanru/zone2/mozilla/central/embedding/components/windowwatcher/src/nsWindowWatcher.cpp:398
#13 0x41b6f9f6 in NS_InvokeByIndex_P (that=0x1921db8, methodIndex=3, paramCount=<value optimized out>, 
    params=<value optimized out>)
    at /home/kanru/zone2/mozilla/central/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp:160
#14 0x4146e3e4 in CallMethodHelper::Invoke (this=0xbe946418)
    at /home/kanru/zone2/mozilla/central/js/xpconnect/src/XPCWrappedNative.cpp:3118
#15 0x4146c9da in CallMethodHelper::Call (this=0xbe946418)
    at /home/kanru/zone2/mozilla/central/js/xpconnect/src/XPCWrappedNative.cpp:2452
#16 0x4146c8b0 in XPCWrappedNative::CallMethod (ccx=..., mode=XPCWrappedNative::CALL_METHOD)
    at /home/kanru/zone2/mozilla/central/js/xpconnect/src/XPCWrappedNative.cpp:2418
#17 0x41477364 in XPC_WN_CallMethod (cx=0x1921ee0, argc=5, vp=0x43f4f100)
    at /home/kanru/zone2/mozilla/central/js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1480
#18 0x421da212 in js::CallJSNative (cx=0x1921ee0, 
    native=0x41477185 <XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*)>, args=...)
    at /home/kanru/zone2/mozilla/central/js/src/jscntxtinlines.h:389
#19 0x421e0a06 in js::InvokeKernel (cx=0x1921ee0, args=..., construct=js::NO_CONSTRUCT)
    at /home/kanru/zone2/mozilla/central/js/src/jsinterp.cpp:351
#20 0x421edc48 in js::Interpret (cx=0x1921ee0, entryFrame=0x43f4f068, interpMode=js::JSINTERP_NORMAL)
    at /home/kanru/zone2/mozilla/central/js/src/jsinterp.cpp:2423
#21 0x421e0728 in js::RunScript (cx=0x1921ee0, script=0x47a57200, fp=0x43f4f068)
    at /home/kanru/zone2/mozilla/central/js/src/jsinterp.cpp:308
#22 0x421e0a96 in js::InvokeKernel (cx=0x1921ee0, args=..., construct=js::NO_CONSTRUCT)
    at /home/kanru/zone2/mozilla/central/js/src/jsinterp.cpp:362
#23 0x4214f5c4 in js::Invoke (cx=0x1921ee0, args=..., construct=js::NO_CONSTRUCT)
    at /home/kanru/zone2/mozilla/central/js/src/jsinterp.h:119
#24 0x421e0c6c in js::Invoke (cx=0x1921ee0, thisv=..., fval=..., argc=1, argv=0xbe9472e0, rval=0xbe947400)
    at /home/kanru/zone2/mozilla/central/js/src/jsinterp.cpp:394
#25 0x42145298 in JS_CallFunctionValue (cx=0x1921ee0, objArg=0x47a595e0, fval=..., argc=1, argv=0xbe9472e0, 
    rval=0xbe947400) at /home/kanru/zone2/mozilla/central/js/src/jsapi.cpp:5890
#26 0x41463e40 in nsXPCWrappedJSClass::CallMethod (this=0x1f07b08, wrapper=0x1f12558, methodIndex=3, 
    info=0x187d0f8, nativeParams=0xbe947638)
    at /home/kanru/zone2/mozilla/central/js/xpconnect/src/XPCWrappedJSClass.cpp:1436
#27 0x4145b86c in nsXPCWrappedJS::CallMethod (this=0x1f12558, methodIndex=3, info=0x187d0f8, params=0xbe947638)
    at /home/kanru/zone2/mozilla/central/js/xpconnect/src/XPCWrappedJS.cpp:580
#28 0x41b703d6 in PrepareAndDispatch (self=<value optimized out>, methodIndex=<value optimized out>, 
    args=0xbe9476f4) at /home/kanru/zone2/mozilla/central/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp:105
#29 0x41b6fa0c in SharedStub () from /home/kanru/zone2/mozilla/B2G/objdir-gecko/dist/bin/libxul.so
#30 0x415f6998 in EnumRun (aHandler=0x1f125a0, aThis=0x1d038a0)
    at /home/kanru/zone2/mozilla/central/toolkit/components/commandlines/nsCommandLine.cpp:622
#31 0x415f64b8 in nsCommandLine::EnumerateHandlers (this=0x1d038a0, aCallback=0x415f697d <EnumRun>, aClosure=0x0)
    at /home/kanru/zone2/mozilla/central/toolkit/components/commandlines/nsCommandLine.cpp:560
#32 0x415f69e2 in nsCommandLine::Run (this=0x1d038a0)
    at /home/kanru/zone2/mozilla/central/toolkit/components/commandlines/nsCommandLine.cpp:634
#33 0x406b5fe8 in XREMain::XRE_mainRun (this=0xbe9479e0)
    at /home/kanru/zone2/mozilla/central/toolkit/xre/nsAppRunner.cpp:3769
#34 0x406b63be in XREMain::XRE_main (this=0xbe9479e0, argc=1, argv=0xbe949bf4, aAppData=0xd2e0)
    at /home/kanru/zone2/mozilla/central/toolkit/xre/nsAppRunner.cpp:3877
#35 0x406b656a in XRE_main (argc=1, argv=0xbe949bf4, aAppData=0xd2e0, aFlags=0)
    at /home/kanru/zone2/mozilla/central/toolkit/xre/nsAppRunner.cpp:3953
#36 0x00008cc4 in do_main (argc=1, argv=0xbe949bf4)
    at /home/kanru/zone2/mozilla/central/b2g/app/nsBrowserApp.cpp:153
#37 0x00008f38 in main (argc=1, argv=0xbe949bf4) at /home/kanru/zone2/mozilla/central/b2g/app/nsBrowserApp.cpp:229
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 783134
You need to log in before you can comment on or make changes to this bug.