Reading does not immediately mark message read on server

VERIFIED DUPLICATE of bug 24787

Status

MailNews Core
Networking: IMAP
VERIFIED DUPLICATE of bug 24787
18 years ago
10 years ago

People

(Reporter: u27431, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I have this problem with 0.8.1 and don't know if it's specific to IMAP or not. 
In any event, if I receive a new message and read it, the message remains marked
as "UNREAD" (NEW?) on the sever until I issue a "Compact Folder" command.  I
have verified this by sending myself messages, reading, and then checking with
another client (Pine).  

Where this becomes a problem is that "mail checking" programs that show when you
have new mail will continue to register new mail after you have read the mail
unless you compact after reading (which is a pain).  Perhaps it's a bad idea to
be making connections only to mark read after each message but could the client
at least do a batch update a few minutes after reading?  Perhaps it already does
something like this (doesn't appear to)?

Note that issuing a "Get Message" shortly after reading a message can even
sometimes result in the client switching the client state of a read message back
to New/Unread! (i.e. it now appears unread again to the user - it never was
marked read on the server).

Mail me if this is too confusing. :)

(Btw, keep up the good work folks!)

Updated

18 years ago
QA Contact: esther → huang

Comment 1

17 years ago
Duplicate of Bug 24787.  Fixed 4/17, after 0.8.1 release.

*** This bug has been marked as a duplicate of 24787 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
I do not believe this bug is a duplicate of the bug 24787, although it might be
related.  I still see the problem as described in my original report in the
Linux 0.9.1 release.

I can replicate the problem trivially.

1) Send yourself a message.
2) Hit "Get Messages" to get see the new header.
3) Select the new message to read it.
4) Leave it selected and use another mail client (Pine) or mail check program to
look for new mail.

You will see that the message has an unread/new status on the server.
Closing Mozilla Mail/News or using "Compact Folder" may cause it to be marked
read.  Sometimes reading another message will cause it to be marked read but not
always.  I'm guessing that it only updates the flags when it needs to contact
the server, and that if you click on a message that happens to be cached, the
flags are not set.  If you click on an uncached message, the flags are set.

The irritating upshot of all this is that if one receives a message, reads it,
leaves the message selected, and then simply leaves Mail/News running and moves
on to other work, any mail check program (I use the Gnome mailcheck applet) will
continue to indicate a new message waiting.  I see this bug all day every day.

I would suggest updating flags whenever a message is read, or at some short
fixed period after reading (say a minute) if the server has not been contacted
for some other reason in between.

I would mark this bug as reopened but I'm not sure I am meant to do that.

(Reporter)

Comment 4

17 years ago
This problem is still present in 0.9.2.  I suggest reopening this bug.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.