Fix bug in event codegen

RESOLVED DUPLICATE of bug 783376

Status

()

Core
XPConnect
RESOLVED DUPLICATE of bug 783376
6 years ago
6 years ago

People

(Reporter: ted, Assigned: ted)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Simple bug in event_impl_gen.py, the codegen is wrong when there's a cycle-collectable member that's not the last member in the interface.
(Assignee)

Comment 1

6 years ago
Created attachment 652409 [details] [diff] [review]
Fix bug in event codegen
Attachment #652409 - Flags: review?(bugs)

Updated

6 years ago
Attachment #652409 - Flags: review?(bugs) → review+
(Assignee)

Comment 2

6 years ago
smaug fixed this in bug 783376.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 783376
You need to log in before you can comment on or make changes to this bug.