clean-up try build directories at the end of the build (instead of the beginning)

RESOLVED DUPLICATE of bug 712206

Status

P3
enhancement
RESOLVED DUPLICATE of bug 712206
6 years ago
7 months ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Mike Hommey pointed out that if we cleaned up try build directories at the end of the build, that tests could potentially start earlier (because sendchanges would be done prior to cleanup). At times when we have long wait times this probably won't help at all, but it could shave up to 7-10min (the length of time it takes to clean up a windows build directory) off the end to end time in off-peak times.
Note that I think we should cleanup the *previous* objdir at the end of the build, not the current one, as there is value in keeping the objdir around. I've asked files off it more than once, it has value when debugging subtle build issues.
So when we currently remove the old objdir, we should move it away instead, and remove that moved directory at the end of the build.
so something along the lines of

rm -rf build.old
mv build build.old

?
Severity: normal → enhancement
Priority: -- → P3
Product: mozilla.org → Release Engineering
This will be fixed by slave preflight tasks
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712206
(Assignee)

Updated

7 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.