Closed Bug 783271 Opened 7 years ago Closed 7 years ago

Intermittent crash in browser_bug557943.js [@ js::mjit::Compiler::finishThisUp]

Categories

(Core :: JavaScript Engine, defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 735472

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: crash, intermittent-failure)

Crash Data

Rev4 MacOSX Lion 10.7 mozilla-inbound debug test mochitest-other on 2012-08-15 14:19:10 PDT for push 2f0808dd3a11

slave: talos-r4-lion-031

https://tbpl.mozilla.org/php/getParsedLog.php?id=14415594&tree=Mozilla-Inbound

{
TEST-PASS | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_bug557943.js | Should be displaying the correct UI
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_bug557943.js | must wait for load
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_bug557943.js | must wait for focus
++DOMWINDOW == 57 (0x14db92030) [serial = 10359] [outer = 0x142c1a9e0]
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: No outer window available!: file ../../../dom/base/nsGlobalWindow.cpp, line 9154
WARNING: Must complete empty transaction when compositing!: file ../../../layout/base/nsPresShell.cpp, line 5303
WARNING: NS_ENSURE_TRUE(mTextInputHandler) failed: file ../../../widget/cocoa/nsChildView.mm, line 4075
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_bug557943.js | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:43:38.188869
INFO | automation.py | Reading PID log: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpkYfCtBpidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64-debug/1345064640/firefox-17.0a1.en-US.mac64.crashreporter-symbols.zip
PROCESS-CRASH | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_bug557943.js | application crashed (minidump found)
Crash dump filename: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpcOGyUM/minidumps/02B2DAF9-A5C3-49F2-BD0D-DD757F6E4483.dmp
Operating system: Mac OS X
                  10.7.2 11C74
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x21

Thread 0 (crashed)
 0  XUL!js::mjit::Compiler::finishThisUp [Compiler.cpp : 1323 + 0x0]
    rbx = 0x14518d38   r12 = 0x00001cdf   r13 = 0x00000005   r14 = 0x5fbf3c78
    r15 = 0x00001cdf   rip = 0x02e76fca   rsp = 0x5fbf37e0   rbp = 0x5fbf3b90
    Found by: given as instruction pointer in context
 1  XUL!js::mjit::Compiler::emitReturn [Compiler.cpp : 3831 + 0xe]
    rip = 0x02e7ece1   rsp = 0x5fbf3820
    Found by: stack scanning
 2  XUL!js::mjit::FrameState::rawPush [FrameState-inl.h : 211 + 0x7]
    rip = 0x02eacee0   rsp = 0x5fbf3840
    Found by: stack scanning
 3  XUL!js::mjit::Compiler::generateMethod [Compiler.cpp : 3276 + 0x7]
    rip = 0x02e75db2   rsp = 0x5fbf3890
    Found by: stack scanning
}
You've been a very very bad slave, badslave.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: talos-r4-lion-031
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.