Incoming call screen does not show up in full screen video

RESOLVED INVALID

Status

Firefox OS
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: diego, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Open the video app and played a video. Then called the phone.


Actual results:

I could hear the "incoming call" ring, bug only the video was displaying on the screen. There was no "incoming call" notification.


Expected results:

I expected the "incoming call" screen to show app as it does on any other app.
Guys, how is this expected to work?
blocking-basecamp: --- → +
This is a Gaia issue. The incoming call screen should be on top of it. Basically and as far as I understand, fullscreen force http://mxr.mozilla.org/mozilla-central/source/layout/style/ua.css#223 and notably |z-index: 2147483647 !important;|. The solution for us is to make sure the incoming call have a correct z-index and is at the correct place in the DOM hierarchy while fullscreen is turned on.
Closing and I have opened https://github.com/mozilla-b2g/gaia/issues/3515
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Video is apparently the only app that calls mozRequestFullScreen().  I thought camera did it to, but it is getting fullscreen from its manifest.

Gallery will have the same bug when I restore fullscreen functionality there.

Adding Tim to the cc list since Vivien says this is a z-index issue. Can't find bugmail for Alive
This is a Gaia bug, I'll continue the conversation over at https://github.com/mozilla-b2g/gaia/issues/3515
You need to log in before you can comment on or make changes to this bug.