[MWC 2013] Technology page needs updated

RESOLVED DUPLICATE of bug 830933

Status

RESOLVED DUPLICATE of bug 830933
6 years ago
6 years ago

People

(Reporter: dangoor, Assigned: sgarrity)

Tracking

unspecified
Future
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=content p=3, URL)

(Reporter)

Description

6 years ago
The Technology page is out of date with respect to developer tools, especially for Firefox 15.

* it needs the Style Editor, which was introduced a few releases ago
* it should probably include the 3D View of the page inspector
* Firefox 15 adds the Responsive Design View
* It also adds the Debugger, including remote debugging capabilities for Fennec, as seen here: https://hacks.mozilla.org/2012/08/remote-debugging-on-firefox-for-android/
Blocks: 766691
Whiteboard: [sp-2012-08-28] u=user c=fx15 p=3
Laura, can you review comment#1 and provide copy and content for these updates?
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Component: General → Pages & Content
Assignee: nobody → lforrest
Whiteboard: [sp-2012-08-28] u=user c=fx15 p=3 → u=user c=fx15 p=3
Target Milestone: --- → Future
Assignee: lforrest → nobody
Component: Pages & Content → Project Tracking
OS: Mac OS X → All
Hardware: x86 → All
Component: Project Tracking → Pages & Content
Laura/Malexis: Is this bug no longer relevant?
(Reporter)

Comment 3

6 years ago
This bug remains relevant. Firefox 16 added the Developer Toolbar. We've also got remote debugging now, which will be interesting with our push to mobile. We should consider expanding beyond the Technology page for the developer tools... maybe for Firefox 20 (with the landing of the Developer Toolbox and the Profiler), but it seems like an update to the technology page is worthwhile.

Comment 4

6 years ago
+1 - let's do this during the MWC update batch, or sooner. This is on me to work with Kevin to completion.
Priority: -- → P1
Summary: Technology page needs update for Firefox 15 → [MWC2013] Technology page needs update for Firefox 15

Updated

6 years ago
Priority: P1 → --

Updated

6 years ago
Summary: [MWC2013] Technology page needs update for Firefox 15 → [MWC2013] Technology page needs updated
Assigning over to laura. Let us know when ready for implementation
Assignee: nobody → lforrest

Updated

6 years ago
No longer blocks: 766691

Updated

6 years ago
Blocks: 824782
Whiteboard: u=user c=fx15 p=3 → u=user p=3
Whiteboard: u=user p=3 → u=user c=content p=3

Comment 6

6 years ago
Update here: since Kevin has moved on, I'm working with Joe Walker and Rob Campbell to get the information needed to update this page.

Comment 7

6 years ago
Update: the creative brief is available here: https://docs.google.com/a/mozilla.com/document/d/1lIn9YDAtwIVCSTRmkqapJvnwv1fGtTpN4_CqeKejKOo/edit

We're having a creative kickoff next Tuesday. I'm having Rob and Joe review the doc above before that point.

Comment 8

6 years ago
Kickoff complete. See the document above.

Comment 9

6 years ago
Let's use this bug as the implement bug. 

Graphics being created in Bug 830933.
Assignee: lforrest → malexis
Depends on: 830933
Assignee: malexis → steven
Summary: [MWC2013] Technology page needs updated → [MWC 2013] Technology page needs updated
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830933
You need to log in before you can comment on or make changes to this bug.