Last Comment Bug 783376 - codegenerator should be able generate implementations which inherit other simple events
: codegenerator should be able generate implementations which inherit other sim...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug] (vacation Aug 25-28)
:
Mentors:
: 783234 (view as bug list)
Depends on:
Blocks: 604039 783856
  Show dependency treegraph
 
Reported: 2012-08-16 14:05 PDT by Olli Pettay [:smaug] (vacation Aug 25-28)
Modified: 2012-11-15 05:26 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (6.31 KB, patch)
2012-08-16 14:18 PDT, Olli Pettay [:smaug] (vacation Aug 25-28)
khuey: review+
Details | Diff | Splinter Review
example .cpp (40.37 KB, text/plain)
2012-08-16 14:21 PDT, Olli Pettay [:smaug] (vacation Aug 25-28)
no flags Details

Description Olli Pettay [:smaug] (vacation Aug 25-28) 2012-08-16 14:05:12 PDT
Patch coming
Comment 1 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-08-16 14:18:09 PDT
Created attachment 652566 [details] [diff] [review]
patch

this simplifies CC handling so that all the generated classes have the
CC related macros and forward calls to parent, eventually nsDOMEvent which is
anyway cycle collectable.
Comment 2 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-08-16 14:21:45 PDT
Created attachment 652570 [details]
example .cpp

This is an example .cpp when I added nsIDOMClose2Event which inherited
nsIDOMCloseEvent, and nsIDOMClose3Event which inherited nsIDOMClose2Event.

(2 and 3 added foobar2 and foobar3 properties, and to test CC stuff, I added
also target2 and target3)
Comment 3 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-08-16 14:23:23 PDT
https://tbpl.mozilla.org/?tree=Try&rev=3b7edd610419
Comment 4 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-08-16 14:25:12 PDT
Ted, with this patch the patch you wrote earlier today isn't needed to fix CCable member variable issue you got.
Comment 5 Ted Mielczarek [:ted.mielczarek] 2012-08-16 14:28:03 PDT
If you just want to dupe bug 783234 to this, that's fine. I haven't landed it yet.
Comment 6 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-08-16 14:30:15 PDT
Depends on when khuey might have time to review this. Or you can review this too ;)
Comment 7 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-08-20 14:08:34 PDT
https://hg.mozilla.org/mozilla-central/rev/36e366621f46
Comment 8 Ted Mielczarek [:ted.mielczarek] 2012-11-15 05:26:57 PST
*** Bug 783234 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.