Duplicated Layout on Page

RESOLVED INVALID

Status

Tech Evangelism
Desktop
RESOLVED INVALID
6 years ago
4 years ago

People

(Reporter: Chris B., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 652571 [details]
Funky Layout.jpg

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Load www.jobcircle.com and look at the funky layout issue in the left column.  Each item is duplicated and can also be used (both text boxes, links, listboxes, etc can all be clicked).  Does not occur in Internet Explorer 10.0.8400.0.  Using Firefox 14.0.1.


Actual results:

Layout messed up on left.


Expected results:

Layout should be correct.

Comment 1

6 years ago
Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/09aa6c7e5867
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110602 Firefox/7.0a1 ID:20110602165615
Bad:
http://hg.mozilla.org/mozilla-central/rev/8a133638f5b6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110602 Firefox/7.0a1 ID:20110602225429
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=09aa6c7e5867&tochange=8a133638f5b6


Suspected: Bug 661471



It seems to fix, if I set gfx.font_rendering.cleartype_params.force_gdi_classic_max_size to 0
Blocks: 661471
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: 14 Branch → 7 Branch
This looks like a page bug and you can see the same layout problem in IE if you change the zoom with ctrl+ and ctrl- . Opera12 shows the same layout as Firefox on my system.
The layout is ok in Firefox14.0.1 if you start Firefox without hardware acceleration (unless you zoom).

I guess that this issue depends on the font metrics ...

Comment 3

6 years ago
Confirmed Opera12 shows same as Firefox.
I can see in Google Chrome21 when zoom in.

This is definitely the site bug
No longer blocks: 661471

Updated

6 years ago
Keywords: regression
Assignee: nobody → english-us
Component: Untriaged → English US
Product: Firefox → Tech Evangelism
Version: 7 Branch → unspecified

Comment 4

4 years ago
INVALID.
No more columns on the left, no more duplications.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.