Last Comment Bug 783449 - popup menus show highlighted item from last time they were open
: popup menus show highlighted item from last time they were open
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: Trunk
: x86 All
: -- normal with 1 vote (vote)
: mozilla17
Assigned To: Matt Woodrow (:mattwoodrow)
:
Mentors:
: 784137 (view as bug list)
Depends on: 832641
Blocks: 782413
  Show dependency treegraph
 
Reported: 2012-08-16 19:14 PDT by Cameron McCormack (:heycam)
Modified: 2013-02-26 07:55 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Move the NeedsPaint code into android (1.77 KB, patch)
2012-08-19 19:44 PDT, Matt Woodrow (:mattwoodrow)
roc: review+
Details | Diff | Review

Description Cameron McCormack (:heycam) 2012-08-16 19:14:40 PDT
I don't know if this is a widget or gfx problem.  With current Nightlies on Mac, if I open a popup menu that I recently selected an item from, when it opens the last selected item is shown highlighted, when instead it should show no items highlighted.

STR:

1. Right click on a page's content.
2. Click View Page Info.
3. Close the Page Info window.
3. Right click again on the page's content.
4. Notice that View Page Info is initially highlighted, when it shouldn't be.
Comment 1 Steven Michaud [:smichaud] (Retired) 2012-08-17 08:02:57 PDT
Please try to find a regression range among mozilla-central nightlies.

My hunch is that you'll find the 2012-08-14 nightly has this problem and the 2012-08-13 nightly doesn't.
Comment 2 Cameron McCormack (:heycam) 2012-08-17 22:12:56 PDT
The first bad revision is:
changeset:   102212:22f6adf8685b
user:        Matt Woodrow <matt.woodrow@gmail.com>
date:        Mon Aug 13 19:41:09 2012 -0700
files:       view/src/nsViewManager.cpp widget/gonk/nsWindow.cpp widget/gonk/nsWindow.h
description:
Bug 782413: Only paint widgets that have a layer manager. r=cjones
Comment 3 Matt Woodrow (:mattwoodrow) 2012-08-19 19:44:47 PDT
Created attachment 653241 [details] [diff] [review]
Move the NeedsPaint code into android

This happens when we flush an invalid region to the widget, but don't actually paint anything.

This check was only really for android/gonk which have multiple widgets, but only ever paint one of them.
Comment 4 Matt Woodrow (:mattwoodrow) 2012-08-20 03:03:14 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1f6cd8529ae9
Comment 5 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-20 19:10:41 PDT
are either this bug or bug 784137 dupes of bug 784117?
Comment 6 Cameron McCormack (:heycam) 2012-08-20 19:31:50 PDT
I think they probably both are.
Comment 7 Alice0775 White 2012-08-20 19:37:30 PDT
*** Bug 784137 has been marked as a duplicate of this bug. ***
Comment 8 Ed Morley [:emorley] 2012-08-21 06:33:17 PDT
https://hg.mozilla.org/mozilla-central/rev/1f6cd8529ae9
Comment 9 Benoit Girard (:BenWa) 2012-09-18 15:15:57 PDT
I'm actually still getting this for the first frame the awesomebar is openned :(. I'm guessing 17 is still affected as well.

https://dl.dropbox.com/u/10523664/Screenshots/bugzilla-awesomebar-open.mp4
Comment 10 Alex Keybl [:akeybl] 2012-10-03 16:01:03 PDT
(In reply to Benoit Girard (:BenWa) from comment #9)
> I'm actually still getting this for the first frame the awesomebar is
> openned :(. I'm guessing 17 is still affected as well.
> 
> https://dl.dropbox.com/u/10523664/Screenshots/bugzilla-awesomebar-open.mp4

Any progress here? We'll likely untrack soon if this continues to go unfixed. It's not super critical for release.
Comment 11 Benoit Girard (:BenWa) 2012-10-03 16:31:50 PDT
I don't see this anymore on 2012-10-03
Comment 12 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-16 15:19:04 PDT
Looks like we're done here then, untracking.

Note You need to log in before you can comment on or make changes to this bug.