If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Debugger doesn't see data: URLs.

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: espadrine, Assigned: past)

Tracking

15 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Steps to reproduce:

1. Open a new tab.
2. Enter the following URL: data:text/html,<!doctype html><title></title><script>alert('hi'); o.c = 5</script>
3. Open the debugger.

What fails:
4. The debugger does not show the script that is run, so we cannot debug it.

What should happen:
4. The script is listed in the debugger, so that we can work on it.
(Reporter)

Comment 1

5 years ago
Actually, it doesn't seem to be about data: URLs.

The following page doesn't show the inline script as well: <http://jsbin.com/amanep/2>.
(Reporter)

Comment 2

5 years ago
Additional note: the link in comment #1 does force the debugger to show the script
if you check the “Pause on exceptions” box, and reload the page.
looks like these event listener scripts are being scavenged before the debugger is activated. Pause on Exceptions is no longer needed with the recent reload fixes which feels like an improvement.
Priority: -- → P2
QA Contact: past
Assignee: nobody → past
QA Contact: past
I think both cases now work as expected, after bug 783393. As Rob mentions, we can't display the source without a reload (regardless of the pause-on-exceptions toggle), because the scripts have been scavenged after execution and before the debugger is activated.
Resolving per comment 4.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.