[rule view] Can't copy text from the editor

RESOLVED DUPLICATE of bug 788458

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 788458
5 years ago
5 years ago

People

(Reporter: paul, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
When the editor is open, selecting text in it and then doing ctrl-c doesn't copy the right text.
Created attachment 658136 [details] [diff] [review]
Fix

This patch fixes this issue but the context menu still does not have "copy selection" enabled. This is because of a browser bug that fails to detect whether text is selected in all situations (in our case within our editor).

Unfortunately, logging a new bug ... or rather, creating a reproduce-able test case would be very difficult.
Attachment #658136 - Flags: review?(paul)
Comment on attachment 658136 [details] [diff] [review]
Fix

After some discussion we have decided to always allow allow copy from the context menu.
Attachment #658136 - Flags: review?(paul)
Comment on attachment 658136 [details] [diff] [review]
Fix

Because we cannot get the selection from the input field we cannot copy the text using the context menu (we would need to know where the range starts and ends).

Seems like this is the best we can do.
Attachment #658136 - Flags: review?(paul)
(Reporter)

Comment 4

5 years ago
Comment on attachment 658136 [details] [diff] [review]
Fix

Not sure if I'm supposed to review attachment 658136 [details] [diff] [review] after the discussion we had. 

Anyway:

> Because we cannot get the selection from the input field

Can you file a bug please?

This patch doesn't seem to work for me. Also, I still see the greyed menuitem.
Attachment #658136 - Flags: review?(paul) → review-
(Reporter)

Updated

5 years ago
Blocks: 794254
Fixed in bug 788458
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 788458
You need to log in before you can comment on or make changes to this bug.