`spinning' cursor on Mac should have a 1px white outline

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
trivial
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: Andrew Thompson)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 2001043008, Mac OS 9.1

To reproduce:
*   Go to <http://segfault.org/>. For best results, do this on a slow
    connection, and clear your cache first.
*   While the images are loading, move the cursor over part of the black
    background.

What you see:
*   Two little white triangles.

What you should see:
*   A white outline of a pointing arrow, and a white outline of a beachball (of
    which two little white triangles are a part).

This is as a result of the new cursor resource which was checked in to fix bug 
49173. The cursors I drew are here:
*   <http://bugzilla.mozilla.org/showattachment.cgi?attach_id=13680>
*   <http://bugzilla.mozilla.org/showattachment.cgi?attach_id=13681>
*   <http://bugzilla.mozilla.org/showattachment.cgi?attach_id=13682>
*   <http://bugzilla.mozilla.org/showattachment.cgi?attach_id=13683>

In that bug, I wrote:
|
| I can't tell from Apple's documentation whether the white outline around
| cursors is part of the cursor, or whether it's added by Mac OS; I'm guessing
| the latter. If it's the former, let me know and I'll add the outline and
| attach revised versions.

Obviously my guess was wrong. But how do I add the outline for someone to check 
it in? Is it as simple as making a three-color GIF, where the three colors are 
black, white, and transparent?
(Reporter)

Updated

17 years ago
Blocks: 78363
no gif, you need to give us a 'CURS' resource, made from resEdit or resourcerer.
(Reporter)

Comment 2

17 years ago
Created attachment 32757 [details]
rsrc file containing the four CURSs, only one of which will probably be seen for a while :-)

Comment 3

17 years ago
The outline comes from the mask used in the CURS resource. Does this attachment 
fix that?
(Assignee)

Comment 4

17 years ago
Did you binhex the attachment before sending it? The resource fork seems to be 
gone!

Comment 5

17 years ago
I tweaked the mask of the existing ball/pointer cursor, and checked it in. So 
this bug should remain only if we want the ball to spin.
Summary: `spinning' cursor on Mac should have a 1px white outline → Pointer/ball cursor on Mac should spin
(Reporter)

Comment 6

17 years ago
Created attachment 33333 [details]
Binhexed version of the above file
(Reporter)

Comment 7

17 years ago
As noted in the dependency (which might now be the wrong way round?), making 
the cursor spin is a separate bug -- bug 78363. So assuming Simon just tweaked 
the mask of the single static cursor, the masks for the other three cursors 
still need to be changed.
Summary: Pointer/ball cursor on Mac should spin → `spinning' cursor on Mac should have a 1px white outline

Comment 8

15 years ago
Spinning cursor in 20030311 OSX has white outline.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 9

15 years ago
It still doesn't look right though.
Zooming in I see that the cursor isn't actually the right shape on OS X.

I guess that's a new bug though.
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.