Closed Bug 783780 Opened 10 years ago Closed 9 years ago

Hovering a <splitmenu> item ("Print...") leaves an open <menu> item ("Web Developer") highlighted for a while

Categories

(Firefox :: Menus, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: j.moz, Unassigned)

References

Details

Attachments

(3 files)

Steps to reproduce:

1. Click Firefox button
2. Move mouse cursor over the "Web Developer" menu item
3. Wait until the Web Developer menu opens
4. Move mouse cursor over the "Print..." menu item

Expected: "Web Developer" menu item should be unhighlighted when "Print..." becomes highlighted

What happens: "Web Developer" menu item stays highlighted (until the "Print..." menu opens)

Windows XP, latest nightly, 17.0a1 (2012-08-17).
Not a regression, also happens in Firefox 4.0
Attached image Screenshot after step 4
Screenshot: if you follow the steps to reproduce above, this is what happens right after step 4.

Only "Print..." should be highlighed. Highlighting more than one menu item at a time is a bug. It doesn't happen anywhere else in the menu.
Attached image Animation
Animation: added a blue arrow and some red circles to highlight the bug.

Note that the bug doesn't appear when hovering over the expansion arrows (as seen on the animation on the right).
This seems to be a <splitmenu> bug.

Hovering a <splitmenu> item (e.g. "Print...") after hovering an open <menu> item (e.g. "Web Developer") should remove the <menu> item's _moz-menuactive immediately.

The screenshot shows the problem (inspecting chrome://browser/content/browser.xul with Firebug)
Blocks: 613156
Summary: Web Developer menu item remains highlighted for a while after hovering Print... → Hovering a <splitmenu> item ("Print...") leaves an open <menu> item ("Web Developer") highlighted for a while
The Firefox button is going to be removed in bug 863753.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.