Last Comment Bug 783791 - When re-launching Firefox into maximized window, tabs start out below Firefox button and then shift up to the titlebar
: When re-launching Firefox into maximized window, tabs start out below Firefox...
Status: RESOLVED FIXED
[Snappy:P1] fixed by bug 782980
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86_64 Windows 7
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 782980
Blocks: 770000
  Show dependency treegraph
 
Reported: 2012-08-18 10:13 PDT by Asa Dotzler [:asa]
Modified: 2012-12-17 10:20 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Asa Dotzler [:asa] 2012-08-18 10:13:25 PDT
(note, this is not the same as bug 763269)

On Windows 7, with the latest nightly build (and possibly releases) if you exit Firefox from a maximized window and then re-launch, there is a split second where tabs are below the Firefox button in their own tab strip before they shift up to the titlebar where they're supposed to be. This is really quite ugly and makes Firefox feel very slow. I'm asserting this is a snappy:p1 because users see it every time they start and start-up time is our number one performance complaint.
Comment 1 Dão Gottwald [:dao] 2012-08-18 12:02:02 PDT
This is a recent regression.
Comment 2 Asa Dotzler [:asa] 2012-08-20 10:06:50 PDT
We shouldn't ship this regression. QA, can you help us find the regression window?
Comment 3 Alice0775 White 2012-08-20 18:33:12 PDT
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c14e2d5f17de
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813105346
Bad:
http://hg.mozilla.org/mozilla-central/rev/75cdb3f932c6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813110945
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c14e2d5f17de&tochange=75cdb3f932c6


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ed614ea130c0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813024745
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6a0b53d78465
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813031248
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ed614ea130c0&tochange=6a0b53d78465
Comment 4 Asa Dotzler [:asa] 2012-08-20 19:51:00 PDT
(In reply to Alice0775 White from comment #3)

Thank you, Alice0775!  Matt, can you look into this? This is a severe enough regression that we need a fix or a back out before we uplift to Aurora.
Comment 5 Alice0775 White 2012-08-20 22:26:31 PDT
Last good: 6723b36d8bfa
First bad : 0ad204385022

triggered by:
0ad204385022	Matt Woodrow — Bug 770000 - Call WillPaint and DidPaint from the refresh driver instead of the widget events. r=roc
Comment 6 Matt Woodrow (:mattwoodrow) 2012-08-21 03:12:55 PDT
I can reproduce this with the nightly, but not with the latest mozilla-inbound build.

I think this is probably fixed by bug 782980 which landed today.

Note You need to log in before you can comment on or make changes to this bug.