tabs do not reload after crash

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: illumilore, Unassigned)

Tracking

14 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2013-02-18][notacrash])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713224749

Steps to reproduce:

After a crash, clicked restore session


Actual results:

tabs did restore or load until after they were clicked


Expected results:

tabs should have restored after the restore tabs button was clicked, since it implies that clicking it will restore the tabs
This is intended and was implemented with the feature Expose prefs for tabs-on-demand. 
https://bugzilla.mozilla.org/show_bug.cgi?id=648683

You can return to the old behavior by unchecking the box "Don't load tabs until selected" (Edit menu -> Preference -> Tabs).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

6 years ago
There is no option for Don't load tabs until selected, so something must still be broken in the tabs menu. Only open new windows in a new tab, warn me when closing multiple tabs, warn me when opening..., always show tab bar, switch to new tab immediately.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

6 years ago
It shows here.
Do you see anything in the error console?
Flags: needinfo?(illumilore)
Whiteboard: [closeme 2013-02-18][notacrash]
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

6 years ago
Flags: needinfo?(illumilore)
You need to log in before you can comment on or make changes to this bug.