Last Comment Bug 783835 - Compositor needs to know the css property being animated
: Compositor needs to know the css property being animated
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: David Zbarsky (:dzbarsky)
:
Mentors:
Depends on: 831791
Blocks: 783893
  Show dependency treegraph
 
Reported: 2012-08-18 17:32 PDT by David Zbarsky (:dzbarsky)
Modified: 2013-01-17 11:03 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (12.49 KB, patch)
2012-08-18 17:40 PDT, David Zbarsky (:dzbarsky)
roc: review+
Details | Diff | Splinter Review

Description David Zbarsky (:dzbarsky) 2012-08-18 17:32:24 PDT
This is needed since some properties have different interpolation rules.
Comment 1 David Zbarsky (:dzbarsky) 2012-08-18 17:40:15 PDT
Created attachment 653118 [details] [diff] [review]
Patch
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-08-19 17:39:04 PDT
Comment on attachment 653118 [details] [diff] [review]
Patch

Review of attachment 653118 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with that fixed.

::: gfx/layers/ipc/CompositorParent.cpp
@@ +658,5 @@
>      SampleValue(portion, animation, animData.mStartValues[segmentIndex],
>                  animData.mEndValues[segmentIndex], &interpolatedValue);
>      ShadowLayer* shadow = aLayer->AsShadowLayer();
>      switch (interpolatedValue.type()) {
> +    case Animatable::Tfloat:

Shouldn't we switch on the property name here, not the type?
Comment 3 David Zbarsky (:dzbarsky) 2012-08-20 06:36:21 PDT
Yes, good catch.
https://hg.mozilla.org/integration/mozilla-inbound/rev/e4714af49469
Comment 4 Ed Morley [:emorley] 2012-08-21 06:32:39 PDT
https://hg.mozilla.org/mozilla-central/rev/e4714af49469

Note You need to log in before you can comment on or make changes to this bug.