white Flashing on Transition of animated Images

RESOLVED FIXED in Firefox 17

Status

()

Core
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: xtc4uall, Assigned: khuey)

Tracking

({regression})

17 Branch
mozilla17
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17+ verified)

Details

(Whiteboard: [fixed by Bug 783015], URL)

(Reporter)

Description

5 years ago
Load URL and watch the Transition of the animated Images in the first Loop.
Further Loops seem cached and there's no Issue.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120818030604

Last good nightly: 2012-08-15
First bad nightly: 2012-08-16

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=86ee4deea55b&tochange=50e4ff05741e

by Guess: Bug 697230/Bug 685516
Well both of those point the finger at Kyle, so assigning to him for more investigation.
Assignee: nobody → khuey
tracking-firefox17: ? → +
(Reporter)

Comment 2

5 years ago
I could be wrong, but it seems as if Bug 783015 mitigated/fixed the Issue. Will verify later on by checking Tinderbox Builds....
(Reporter)

Comment 3

5 years ago
Ok, I call this fixed =)

With http://hg.mozilla.org/mozilla-central/rev/1b51c7bf1e05 of http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1345574461/

-> Issue

with http://hg.mozilla.org/mozilla-central/rev/e33c175f6807 of http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1345591366/

-> no Issue(s) anymore

=> fixed Range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1b51c7bf1e05&tochange=e33c175f6807

Thus this is/was indeed a Regression of Bug 697230.
Blocks: 697230
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 783015
Resolution: --- → FIXED
Whiteboard: [fixed by Bug 783015]

Updated

5 years ago
status-firefox17: --- → fixed
Target Milestone: --- → mozilla17
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 beta 4
Build ID: 20121031065642

I can still spot some flashes on the first loop in Firefox 17.0 Beta 4, then it works fine.

Could not reproduce in latest Nightly.

Anyone else seeing this in Beta? XtC4UaLL?
(Reporter)

Comment 5

5 years ago
Yep, you're right: there's still a one-time Flashing in the first Loop for me using 

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20121106195758

But Comment 2 is true though; it's been mitigated compared to before Bug 783015 got checked in.

WFM against Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121108042012.

I presume it got fixed fully in the 18 Cycle and this should be wontfixed for 17.
Thanks. 

We won't be able to set this to verified, but this isn't severe enough to actually re-open (there is an improvement as compared to the original report.). 

Any suggestions from people who worked on bug 783015? Kyle?
Anthony, do you have any suggestions here?
Actually, same question for Olli (his patches fixed a part of this bug through bug 783015).

Comment 8

5 years ago
bug 783015 was about performance and power usage. Don't know about flashing/painting.
I think it's safe to mark this verified for Firefox 17. We know it's not 100% fixed but it's pretty close. I think it's sufficient to let it ride Firefox 18 to release and call this done.
status-firefox17: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.