Last Comment Bug 784037 - missing whitespace between icon and label in chat
: missing whitespace between icon and label in chat
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: Thunderbird 18.0
Assigned To: Andreas Nilsson (:andreasn)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 08:08 PDT by Andreas Nilsson (:andreasn)
Modified: 2012-09-16 16:11 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screemhot of the issue (18.25 KB, image/png)
2012-08-20 08:08 PDT, Andreas Nilsson (:andreasn)
no flags Details
patch to fix the issue (590 bytes, patch)
2012-08-20 09:59 PDT, Andreas Nilsson (:andreasn)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Splinter Review
screeenshot of patch in action (16.21 KB, image/png)
2012-08-20 10:00 PDT, Andreas Nilsson (:andreasn)
no flags Details

Description Andreas Nilsson (:andreasn) 2012-08-20 08:08:53 PDT
Created attachment 653389 [details]
screemhot of the issue

works as it should on the other toolbars
Comment 1 Andreas Nilsson (:andreasn) 2012-08-20 09:59:21 PDT
Created attachment 653420 [details] [diff] [review]
patch to fix the issue

This adds mode="full" to the chat toolbar, making it behave like the other toolbars.
Comment 2 Andreas Nilsson (:andreasn) 2012-08-20 10:00:14 PDT
Created attachment 653421 [details]
screeenshot of patch in action
Comment 3 Blake Winton (:bwinton) (:☕️) 2012-08-20 10:29:01 PDT
Comment on attachment 653420 [details] [diff] [review]
patch to fix the issue

Seems to fix it, based on the screenshot, and the patch makes sense.  r=me, ui-r=me.

Later,
Blake.
Comment 4 Richard Marti (:Paenglab) 2012-09-16 03:52:28 PDT
Andreas did we forget this bug? It still applies, so checkin-needed.

Would you ask for approval-comm-aurora to be in TB 17?
Comment 5 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-09-16 04:13:16 PDT
(In reply to Richard Marti [:Paenglab] from comment #4)
> Andreas did we forget this bug?

By the way, the screen shot here was on Linux, but I think we have the same bug or a similar issue on the non-aero version of the Windows theme. That's what it seems on some screenshots I saw on random forums at least (https://d37wxxhohlp07s.cloudfront.net/s3_images/785748/problem%20TB%20chat.JPG?1346408239 for an example).

> Would you ask for approval-comm-aurora to be in TB 17?

I would. Maybe even comm-beta for Tb16.
Comment 6 Richard Marti (:Paenglab) 2012-09-16 04:41:58 PDT
(In reply to Florian Quèze [:florian] [:flo] from comment #5)
> By the way, the screen shot here was on Linux, but I think we have the same
> bug or a similar issue on the non-aero version of the Windows theme. That's
> what it seems on some screenshots I saw on random forums at least
> (https://d37wxxhohlp07s.cloudfront.net/s3_images/785748/problem%20TB%20chat.
> JPG?1346408239 for an example).

I don't see this on XP. I have the mode=full on the toolbar (TB18). But this patch isn't Linux only, it affects also the other platforms and should also solve the issue on your screenshot.
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-09-16 16:11:06 PDT
https://hg.mozilla.org/comm-central/rev/c5da5372bcef

Andreas, please make sure that your hg is configured to generate all the necessary patch metadata. It makes life easier for those checking in on your behalf.
https://developer.mozilla.org/en-US/docs/Creating_a_patch_that_can_be_checked_in

Note You need to log in before you can comment on or make changes to this bug.