Closed Bug 784119 Opened 9 years ago Closed 9 years ago

HTML5 download attribute not working consistently

Categories

(Firefox :: Untriaged, defect)

14 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 676619

People

(Reporter: raymondcamden, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

I'm trying to test the HTML5 download attribute for anchor tags (see 'download' attribute at MDN: https://developer.mozilla.org/en-US/docs/HTML/Element/a). Here is an example test:

<a id="exportLink" download="data.jpg" href="http://www.raymondcamden.com/images/meatwork.jpg">Download Data FAKE</a>



Actual results:

It simply doesn't work. Clicking the link simply loads the jpg in the browser.


Expected results:

The user should be prompted to save the jpg and the filename should be data.jpg.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 676619
You need to log in before you can comment on or make changes to this bug.