Locationbar dropdown show highlighted item from last time they were open

RESOLVED DUPLICATE of bug 783449

Status

()

RESOLVED DUPLICATE of bug 783449
6 years ago
6 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({regression})

17 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/c676b554c7bb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120820030522


Step to Reproduce:
1. Open locationbar with dropdown arrow.
2, Move mouse over any item.
3. Move mouse to the right while staying over the highlighted item, click on page content.
4. Open awesomebar with dropdown arrow again.

Actual Results:
  Highlight remains

Expected Results:
  No highlight remains

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c06577220b1b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120818122001
Bad:
http://hg.mozilla.org/mozilla-central/rev/8c85c83068e7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120819030601
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c06577220b1b&tochange=8c85c83068e7


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d04dd4660c54
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120818231102
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/84bf19883685
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120819013101
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d04dd4660c54&tochange=84bf19883685

Triggered: Bug 782614/Bug 776481


Bug 783449 is similar but different regression range.

Updated

6 years ago
Summary: Locationbar doropdown show highlighted item from last time they were open → Locationbar dropdown show highlighted item from last time they were open
are either this bug or bug 783449 dupes of bug 784117?
(Reporter)

Comment 2

6 years ago
(In reply to Lukas Blakk [:lsblakk] from comment #1)
> are either this bug or bug 783449 dupes of bug 784117?
These bugs are for Mac OS...
(Reporter)

Comment 3

6 years ago
Regression range in comment#0 is not correct.
If I repeat step 1-4, the problem happens before the build.
No longer blocks: 776481
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 784117
(Reporter)

Comment 5

6 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c14e2d5f17de
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813105346
Highlight disappears with flickering:
http://hg.mozilla.org/mozilla-central/rev/75cdb3f932c6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813110945
#1 Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c14e2d5f17de&tochange=75cdb3f932c6

Remain highlight:
http://hg.mozilla.org/mozilla-central/rev/22f6adf8685b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120813194142
#2 Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=75cdb3f932c6&tochange=22f6adf8685b
Duplicate of bug: 783449
(Reporter)

Updated

6 years ago
tracking-firefox17: ? → ---
Duplicate of this bug: 784117
You need to log in before you can comment on or make changes to this bug.