Intermittent test_domstorage_aboutpages.js | 0 == 1, test_telemetry.js | false == true

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Three instances of this, all three with both of those tests failing. With absolutely no actual knowledge, I still want to pin this on https://hg.mozilla.org/integration/mozilla-inbound/rev/f11e42f6678b since it landed the push before the first two instances.

https://tbpl.mozilla.org/php/getParsedLog.php?id=14534300&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-08-20 11:46:46 PDT for push b48a2499872c
slave: talos-r3-fed-060

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>
### XPCOM_MEM_LEAK_LOG defined -- logging leaks to /tmp/tmpytvfPC/runxpcshelltests_leaks.log

TEST-INFO | (xpcshell/head.js) | test 1 pending
Testing: about:mozilla
Check that our value has been correctly stored.

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | [testURI : 37] 1 == 1

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | [testURI : 38] test-item == test-item

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | [testURI : 39] test-value == test-value

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | 0 == 1 - See following stack:
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_throw :: line 451
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: _do_check_eq :: line 545
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_check_eq :: line 566
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js :: testURI :: line 41
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js :: run_test :: line 12
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: _execute_test :: line 315
JS frame :: -e :: <TOP_LEVEL> :: line 1

TEST-INFO | (xpcshell/head.js) | exiting test
WARNING: nsExceptionService ignoring thread destruction after shutdown: file ../../../xpcom/base/nsExceptionService.cpp, line 166
WARNING: OOPDeinit() without successful OOPInit(): file ../../../toolkit/crashreporter/nsExceptionHandler.cpp, line 2219
...
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>
...
TEST-INFO | /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js | checking histogram PLACES_IDLE_FRECENCY_DECAY_TIME_MS

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js | false == true - See following stack:
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_throw :: line 451
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: _do_check_eq :: line 545
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_check_eq :: line 566
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_check_true :: line 580
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js :: <TOP_LEVEL> :: line 23
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js :: check_telemetry :: line 131
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js :: maintenanceObserver :: line 122
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
JS frame :: resource:///modules/PlacesDBUtils.jsm :: PDBU__executeTasks :: line 80
JS frame :: resource:///modules/PlacesDBUtils.jsm :: PDBU__refreshUI :: line 150
JS frame :: resource:///modules/PlacesDBUtils.jsm :: PDBU__executeTasks :: line 54
JS frame :: resource:///modules/PlacesDBUtils.jsm :: <TOP_LEVEL> :: line 282
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-INFO | (xpcshell/head.js) | exiting test
WARNING: nsExceptionService ignoring thread destruction after shutdown: file ../../../xpcom/base/nsExceptionService.cpp, line 166
WARNING: OOPDeinit() without successful OOPInit(): file ../../../toolkit/crashreporter/nsExceptionHandler.cpp, line 2219

https://tbpl.mozilla.org/php/getParsedLog.php?id=14534158&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound opt test xpcshell on 2012-08-20 11:49:56 PDT for push b48a2499872c
slave: talos-r3-fed64-052
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>

TEST-INFO | (xpcshell/head.js) | test 1 pending
Testing: about:mozilla
Check that our value has been correctly stored.

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | [testURI : 37] 1 == 1

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | [testURI : 38] test-item == test-item

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | [testURI : 39] test-value == test-value

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js | 0 == 1 - See following stack:
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_throw :: line 451
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: _do_check_eq :: line 545
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_check_eq :: line 566
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js :: testURI :: line 41
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_domstorage_aboutpages.js :: run_test :: line 12
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: _execute_test :: line 315
JS frame :: -e :: <TOP_LEVEL> :: line 1

TEST-INFO | (xpcshell/head.js) | exiting test
<<<<<<<
...
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>
...
TEST-INFO | /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js | checking histogram PLACES_IDLE_FRECENCY_DECAY_TIME_MS

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js | false == true - See following stack:
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_throw :: line 451
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: _do_check_eq :: line 545
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_check_eq :: line 566
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/head.js :: do_check_true :: line 580
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js :: <TOP_LEVEL> :: line 23
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js :: check_telemetry :: line 131
JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_telemetry.js :: maintenanceObserver :: line 122
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
JS frame :: resource:///modules/PlacesDBUtils.jsm :: PDBU__executeTasks :: line 80
JS frame :: resource:///modules/PlacesDBUtils.jsm :: PDBU__refreshUI :: line 150
JS frame :: resource:///modules/PlacesDBUtils.jsm :: PDBU__executeTasks :: line 54
JS frame :: resource:///modules/PlacesDBUtils.jsm :: <TOP_LEVEL> :: line 282
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-INFO | (xpcshell/head.js) | exiting test
<<<<<<<

https://tbpl.mozilla.org/php/getParsedLog.php?id=14546877&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14547443&tree=Mozilla-Inbound

(Yeah, that's four instances, because another happened already while I was filing.)
My push does add a telemetry histogram (something I've done a couple dozen other times), but it makes no changes to telemetry itself.  Surely adding a histogram doesn't break toolkit/components/places.  Feel free to backout my bug though and re-open it to rule it out: Bug 777328, it can wait a couple days.
By the way, I think there are at least 3 changesets equally likely the cause, each with green try runs. I'm not sure why I'm the only one CC'ed on this bug :)
I've retriggered various runs (see https://tbpl.mozilla.org/?rev=b48a2499872c&tree=Mozilla-Inbound&jobname=fedora and press downarrow). Due to the not so frequent nature of this one, it may take a while before I can retrigger enough (due to having to space them out to avoid coalescing) to work out the culprit.
Everything on https://tbpl.mozilla.org/?rev=f11e42f6678b&tree=Mozilla-Inbound&jobname=fedora and before has come back green - though might just need more retriggers/...

/me gives up for today.
I re-ran it a bunch of times as well. Given that it's ran 40 times with no fails, I think it suggests it could be from a wider number of changesets than the 3 that were in question originally.
Or a narrower number, since it stopped within a few hours, exactly like so many things did while our build system was even more broken than usual and we were having to clobber every few hours.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.