Closed Bug 784257 Opened 8 years ago Closed 8 years ago

tab context menu label "pin as app tab" is meaningless to mere mortals

Categories

(Firefox :: Tabbed Browser, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 769101

People

(Reporter: dietrich, Unassigned)

References

Details

it's a poor metaphor combined with a incorrect simile.

the only people who understand "pin" are those who are genetically constructed to understand Microsoft UIs. Or Pinterest users (but they still wouldn't get this context for it).

and nobody thinks these are anything like apps, so "app tab" is just confusing and wrong, and therefore something to fear and avoid.

should be something like "keep this tab visible" or something that doesn't contain any mixing of metaphors or similes.
Depends on: 769101
(In reply to Dietrich Ayala (:dietrich) from comment #0)
> the only people who understand "pin" are those who are genetically
> constructed to understand Microsoft UIs. Or Pinterest users (but they still
> wouldn't get this context for it).

I don't think I buy that, even though I'm not a native speaker...
https://www.google.com/search?q=pin&tbm=isch
there are girls and cartoons in those search results. no tabs.

i'm curious about something: where did the pin really make it's mark as a user interaction metaphor for keeping a piece of user interface visible, or statically positioned? where has the pin been successful in other browsers, or other software?

another note about those search results: there's *actually a pin* in them. we have no visual pins.
(In reply to Dietrich Ayala (:dietrich) from comment #2)
> there are girls and cartoons in those search results. no tabs.

Most of the images I get are pins. That's what the metaphor refers to.

> i'm curious about something: where did the pin really make it's mark as a
> user interaction metaphor for keeping a piece of user interface visible, or
> statically positioned? where has the pin been successful in other browsers,
> or other software?

Chrome says "Pin tab", and I'm not sure what makes you believe the term has failed in Firefox.
I don't see a good reason to keep this bug separate from bug 769101.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769101
You need to log in before you can comment on or make changes to this bug.