Last Comment Bug 784280 - Netvibes doesn't work on Firefox 17
: Netvibes doesn't work on Firefox 17
Status: RESOLVED FIXED
: regression
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal
: ---
Assigned To: english-us
:
:
Mentors:
: 788413 (view as bug list)
Depends on:
Blocks: 789036
  Show dependency treegraph
 
Reported: 2012-08-21 01:43 PDT by Bartosz Piec
Modified: 2015-04-19 23:39 PDT (History)
11 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Netvibes on Nightly (94.87 KB, image/png)
2012-08-21 01:43 PDT, Bartosz Piec
no flags Details
Netvibes on Opera (161.02 KB, image/png)
2012-08-21 01:44 PDT, Bartosz Piec
no flags Details

Description Bartosz Piec 2012-08-21 01:43:17 PDT
Created attachment 653687 [details]
Netvibes on Nightly

The reader mode of Netvibes doesn't work anymore in current Nightlies. It displays blank page instead of feed list.

To see it go to Netvibes, change its view to Reader mode and try to click on any RSS feed.

I've setup a test account to demonstrate it. Go to http://www.netvibes.com/ and log in using:
login: netvibes.nightly.test@gmail.com
password: NetvibesTest

The attachments show the current view (in Nightly) and the desired view (in Opera).

This is not the same bug as bug 717184.
Comment 1 Bartosz Piec 2012-08-21 01:44:01 PDT
Created attachment 653688 [details]
Netvibes on Opera
Comment 2 Loic 2012-08-21 04:10:46 PDT
It's a recent regression.

m-c
good=2012-08-04
bad=2012-08-05
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=20fc34efd733&tochange=9453cf029b72

Bisecting needs to be done.
Comment 3 Jorge Villalobos [:jorgev] 2012-08-21 07:49:44 PDT
Why was this moved to Extension Compatibility, Jason?
Comment 4 Alice0775 White 2012-08-21 08:49:19 PDT
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/20fc34efd733
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120804004627
Bad:
http://hg.mozilla.org/mozilla-central/rev/0a17cde2a4b6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120804111326
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=20fc34efd733&tochange=0a17cde2a4b6


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/aa100b9efcca
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120803104127
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/87e7abe891a9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120803113827
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=aa100b9efcca&tochange=87e7abe891a9

Suspected: Bug 772733
Comment 5 :Benjamin Peterson 2012-08-21 10:54:12 PDT
Netvibes seems to use MooTools 1.2, so I'm betting it's the same as bug 781796.

*** This bug has been marked as a duplicate of bug 781796 ***
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2012-08-27 13:52:05 PDT
You can't mark evang bugs against different sites as duplicates of each other... they need to be contacted separately, no?

That said, if this problem is widespread enough then ES6 contains() might just need to change. :(
Comment 7 Jeff Walden [:Waldo] (remove +bmo to email) 2012-08-28 19:30:26 PDT
Mootools had an issue with Function.prototype.bind, introduced in ES5.  We got through it.  I'll bet we can do likewise here.
Comment 8 Alex Keybl [:akeybl] 2012-08-29 16:11:52 PDT
Why is bug 781796 in TE, while this bug is in JS Engine? We need to have a plan moving forward - are we going to perform outreach to all affected sites, or resolve in code?
Comment 9 :Benjamin Peterson 2012-08-29 17:34:04 PDT
Waldo, how exactly did Function.prototype.bind work out?
Comment 10 Jeff Walden [:Waldo] (remove +bmo to email) 2012-08-31 14:07:28 PDT
Mootools had a Function.prototype.bind implementation that was incompatible with the ES5 semantics.  When we implemented ES5 semantics in bug 429507, we happened to break pages that used Mootools and expected its semantics.  (I guess they overrode by testing for an existing bind function and not overriding in that case, but I'm not sure/don't remember.)  The next version of Mootools changed their bind semantics to be ES5-compatible, and the few sites that were broken got fixed by the site authors, probably by updating to the fixed version of Mootools.  I don't remember it being more than half a dozen sites or so that broke; we just soldiered on, roughly, and reported the breakage to the few sites that broke.  The (at the time) lack of a fixed Mootools to upgrade to made it a little tricky, but we have no such problem here, as newer Mootools works fine.  It probably helped somewhat that other JS engines were implementing it at the same time, so there was a semi-united front requesting sites to make fixes.

Perhaps amusingly, Mootools 1.2, the last version with this contains issue, was also the last version that had non-ES5-compatible bind semantics.  Versions without this contains bustage, or the bind bustage for that matter, are readily available and have been for awhile.
Comment 11 Jeff Walden [:Waldo] (remove +bmo to email) 2012-08-31 14:18:35 PDT
As far as a plan goes, I think we contact affected sites.  If they move a little slower, in the short term we can just turn off the relevant methods before we do a release (but keep them on in alphas/betas/nightlies), and only put it in a release when we're happy with the site fix rate.
Comment 12 Benoît Zugmeyer 2012-09-03 05:07:50 PDT
I am a frontend dev at Netvibes and we are aware of this issue. We are using a patched version of MooTools with an ES5 compatible Function#bind method, so this particular issue is not about this method, but the ES6 String#contains, which has a slightly different signature of the one in MooTools 1.2. String#contains is used in Element#hasClass, so it breaks the element query selector with classes.

See this MooTools issue for more details https://github.com/mootools/mootools-core/issues/2402

A fix is on its way and will land soon on our production.
Comment 13 bhavana bajaj [:bajaj] 2012-09-05 16:06:04 PDT
sounds like this will be fixed before 11/20(FF17 release), hence untracking
Comment 14 Loic 2012-09-05 16:49:07 PDT
*** Bug 788413 has been marked as a duplicate of this bug. ***
Comment 15 :Benjamin Peterson 2012-10-01 17:29:32 PDT
Fixed now.

Note You need to log in before you can comment on or make changes to this bug.