Last Comment Bug 784297 - Thumbnail for about:home is out of date/incorrect
: Thumbnail for about:home is out of date/incorrect
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 20
Assigned To: Peter Retzer (:pretzer)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 04:00 PDT by Peter Retzer (:pretzer)
Modified: 2012-12-06 06:10 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
affected
affected
verified


Attachments
Screenshot of the issue (167.59 KB, image/png)
2012-08-21 04:00 PDT, Peter Retzer (:pretzer)
no flags Details
The new tumbnails (100.21 KB, application/x-zip-compressed)
2012-11-12 02:42 PST, Peter Retzer (:pretzer)
no flags Details
The new thumbnails (localization friendly) (91.26 KB, application/zip)
2012-11-13 05:29 PST, Peter Retzer (:pretzer)
no flags Details
patch (118.09 KB, patch)
2012-11-14 05:13 PST, Peter Retzer (:pretzer)
sriram.mozilla: review+
Details | Diff | Splinter Review

Description Peter Retzer (:pretzer) 2012-08-21 04:00:45 PDT
Created attachment 653709 [details]
Screenshot of the issue

Bug 715928 added a static thumbnail to be shown when about:home is open in the tabs list, because taking screenshots was not possible on about:home. The layout of about:home has since been overhauled leaving the thumbnail out of date. 
In addition, even if it is updated to show the new styling, the thumbnail doesn't apply to the different layouts of landscape mode and tablets because the thumbnail always just shows the phone portrait mode.

Possible solutions:

1) Update the phone portrait thumbnail (and live with the fact that other layouts do not show a perfectly correct thumbnail)

2) Include a thumbnail for all every layout (probably not wanted, due to increased app size)

3) Use a generic icon/thumbnail that applies to all layouts (e.g. a big house icon)

4) Enable screenshots on about:home (might not be possible)
Comment 1 Peter Retzer (:pretzer) 2012-11-12 02:41:59 PST
I think it's easiest to just go with option 1) for now, since does not seem to be a big deal for anyone at the moment. Anything else could happen in a follow-up. Any other opinions?
Therefore I created the new thumbnails with the same width/height as the old ones. They'd also save us 11,4 KB in size ;-)
Comment 2 Peter Retzer (:pretzer) 2012-11-12 02:42:46 PST
Created attachment 680569 [details]
The new tumbnails
Comment 3 Peter Retzer (:pretzer) 2012-11-13 02:04:39 PST
Ian, can you have a look at the thumbnails I created and check if they work for now? Or do you prefer another solution?
Comment 4 Ian Barlow (:ibarlow) 2012-11-13 05:01:14 PST
Hey thanks for taking a look at this Peter, these look great.

One thing -- I had been meaning to blank out the text, since on larger resolutions it's actually readable and would look incorrect for other locales. 

Would you mind trying one where you remove the "Top Sites" text and thumbnail titles? Keep all the backgrounds in place, just remove the titles.
Comment 5 Peter Retzer (:pretzer) 2012-11-13 05:29:12 PST
Created attachment 681010 [details]
The new thumbnails (localization friendly)

Like this?
Comment 6 Ian Barlow (:ibarlow) 2012-11-13 05:35:03 PST
Yep, thanks Peter.
Comment 7 Peter Retzer (:pretzer) 2012-11-14 05:13:15 PST
Created attachment 681450 [details] [diff] [review]
patch

I always wanted to submit a patch to Firefox, so here is my first try! \o/
No code change, I just swapped the three thumbnails.
Comment 8 Sriram Ramasubramanian [:sriram] 2012-12-03 12:17:00 PST
Comment on attachment 681450 [details] [diff] [review]
patch

Review of attachment 681450 [details] [diff] [review]:
-----------------------------------------------------------------

Oops. Sorry for getting late at this. This looks great :) :)
Comment 9 Peter Retzer (:pretzer) 2012-12-03 12:29:48 PST
Thanks, Sriram! :-)
Comment 10 Sriram Ramasubramanian [:sriram] 2012-12-03 13:22:52 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/a7125bc00ed9
Comment 11 Ryan VanderMeulen [:RyanVM] 2012-12-04 19:08:48 PST
https://hg.mozilla.org/mozilla-central/rev/a7125bc00ed9
Comment 12 Cristian Nicolae (:xti) 2012-12-06 06:10:15 PST
The about:home thumbnail was updated on the latest Nightly. Closing bug as verified fixed on:

Firefox 20.0a1 (2012-12-06)
Device: Galaxy Tab2 7"
OS: Android 4.0.3

Note You need to log in before you can comment on or make changes to this bug.