Bugzilla::WebService returns broken XML when comment contains malformed unicode characters

RESOLVED DUPLICATE of bug 538946

Status

()

Bugzilla
Bugzilla-General
RESOLVED DUPLICATE of bug 538946
6 years ago
5 years ago

People

(Reporter: kupiec.w, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 653720 [details]
malformed_chars.txt

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120310193349

Steps to reproduce:

Type malformed unicode characters into a comment and then try to get Comments withBugzilla::WebService/Bug.comments method.


Actual results:

It returns XML response which is not handled by any XML validator. If you use Bugzilla:REST API for example, you will get:
Aug 21 14:05:43 [ERROR] Caught exception in Bugzilla::API::Controller::Bug->comment "Can't use string ("
not well-formed (invalid token)") as a HASH ref while "strict refs" in use at /lib/Bugzilla/API/Model/Utils.pm line 684."




Expected results:

The XML should be well formated even if comment contains invalid characters, or it should no be possible to type (paste) invalid unicode characters.

Comment 1

6 years ago
Which version of Perl do you have? This problem is not supposed to happen with Perl 5.12 or higher (server side, of course).

Also, do you see the problem with malformed characters only, or with any unicode character (even valid ones)?

This looks like a duplicate of bug 706276 or bug 538946.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538946
You need to log in before you can comment on or make changes to this bug.