[TABLET] Doorhangers point to nowhere

VERIFIED FIXED in Firefox 19

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: ibarlow, Assigned: Margaret)

Tracking

Trunk
Firefox 17
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox19 verified)

Details

Attachments

(2 attachments)

Reporter

Description

7 years ago
On my Nexus 7, doorhangers should be pointing to the favicon, but they aren't at the moment: http://cl.ly/image/3e1N3d2G3W10
Assignee

Comment 1

7 years ago
Does this only happen on the Nexus 7? What about other tablets?
(In reply to Margaret Leibovic [:margaret] from comment #1)
> Does this only happen on the Nexus 7? What about other tablets?

Oh! I actually saw this today in my beta upload run

Scroll down to the Samsung Galaxy Tab 2:

http://www.appthwack.com/public/4kxyti28dl
Assignee

Comment 3

7 years ago
Oh, I think what's happening here is that the popup is so wide that it's hitting the right side of the screen, then getting moved over to the left because of that.

Unfortunately, our calculations for positioning these doorhangers aren't very robust. Lucas, were you looking into that recently?

As a quick-fix solution, we could just change the width of the doorhangers to make sure there's always enough room to the right of the favicon on all devices, especially since it looks like the popup is wider than it really needs to be right now.
Assignee

Comment 4

7 years ago
Posted patch patchSplinter Review
This patch makes the doorhanger popup have the same width as the site identity popup. In the long run, it would be really nice to have some generic arrow panel popup thing that we can fill with whatever we want, but for now this will fix the issue of popups that are too wide.

One concern is that the button text can wrap into two lines for the popups that have 3 buttons, but I'd like to get rid of those in bug 739757. Also, I feel like wrapped button text is a small price to pay to make sure the doorhanger points to the right place :)
Assignee: nobody → margaret.leibovic
Attachment #654701 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 654701 [details] [diff] [review]
patch

Review of attachment 654701 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. I guess you'll have to rebase but it won't involve any big changes to the patch.
Attachment #654701 - Flags: review?(lucasr.at.mozilla) → review+
Assignee

Comment 6

7 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9dd60aeba5b7
OS: Mac OS X → Android
Hardware: x86 → ARM
Target Milestone: --- → Firefox 17
Version: unspecified → Trunk
https://hg.mozilla.org/mozilla-central/rev/9dd60aeba5b7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED

Comment 8

7 years ago
Thia is reproducible on:

Build: Firefox 16.0 Beta 3
Device: ASUS EEE Transformer 
OS: Android 4.0.3

When the tab menu is opened the doorhanger arrow is misaligned as you can see in the screenshot. Should I file a new bug?
Assignee

Comment 9

7 years ago
(In reply to Andreea Pod from comment #8)

> When the tab menu is opened the doorhanger arrow is misaligned as you can
> see in the screenshot. Should I file a new bug?

Yeah,  it looks like we'll need a more robust solution that actually moves the arrow over, since the right side of the doorhanger is still hitting the edge of the screen :/
This issue is still reproducible on the latest Nightly build. Reopening bug

--
Firefox 18.0a1 (2012-09-19)
Device: Galaxy Tab 10.1
OS: Android 3.1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Comment 11

7 years ago
Cristian, what are you seeing? I can't reproduce Andreea's issue on Nightly on my Galaxy Tab.
Assignee

Comment 12

7 years ago
I'm closing this again because I can't reproduce the issue. Please file a new bug with a screenshot if there's a new issue.

(I filed bug 808248 about minor positioning tweaks, so you don't need to file a new bug if you issues match the ones described in that bug.)
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
(In reply to Margaret Leibovic [:margaret] from comment #11)
> Cristian, what are you seeing? I can't reproduce Andreea's issue on Nightly
> on my Galaxy Tab.

I cannot reproduce it either. Besides the issues that you have already mentioned them in bug 808248, I didn't see anything new. I will close this bug as verified fixed on:

Firefox 19.0a1 (2012-11-05)
Devices: Galaxy S2, Galaxy Tab 10.1
OSes: Android 4.0.3, Android 3.1
Status: RESOLVED → VERIFIED
This is still an issue on Firefox Mobile 18 beta 1 on Asus EEE Transformer (Android 4.0.4)
Assignee

Comment 15

7 years ago
(In reply to adrian tamas from comment #14)
> This is still an issue on Firefox Mobile 18 beta 1 on Asus EEE Transformer
> (Android 4.0.4)

Could you take a screenshot? Is this different than bug 808248? If so, could you file a new bug about it?
(In reply to Margaret Leibovic [:margaret] from comment #15)
> (In reply to adrian tamas from comment #14)
> > This is still an issue on Firefox Mobile 18 beta 1 on Asus EEE Transformer
> > (Android 4.0.4)
> 
> Could you take a screenshot? Is this different than bug 808248? If so, could
> you file a new bug about it?

The issue is the same but I saw the second bug only after I had added the comment. Please ignore Comment 14.
You need to log in before you can comment on or make changes to this bug.