JSON parser fails to understand \u00f5

RESOLVED DUPLICATE of bug 783762

Status

Mozilla Developer Network
Editing
RESOLVED DUPLICATE of bug 783762
5 years ago
4 years ago

People

(Reporter: Wladimir Palant (for Adblock Plus info Cc bugzilla@adblockplus.org), Unassigned)

Tracking

Details

Steps to reproduce:

1. Edit any page on MDN.
2. Add the text {{ foo({"prop": "bar\u00f5"}) }} to the page.
3. Click "preview changes" button.

Expected results:

An error message complaining that the template foo doesn't exist (this is what you get without \u00f5).

Actual results:

An error message complaining that "f" was found where only [0-9] was expected.

\u escapes are hexadecimal so it is probably a good idea to change that regexp to [0-9a-fA-F].
This looks like the same problem as bug 783762. Wladimir, did you see a DocumentParsingError when you previewed the page?
Yes, it is the same issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 783762
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified
(Assignee)

Updated

5 years ago
Component: Docs Platform → Editing
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.