font in source view is huge

VERIFIED DUPLICATE of bug 79277

Status

()

Core
Editor
VERIFIED DUPLICATE of bug 79277
17 years ago
17 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Charles Manske)

Tracking

({pp, regression})

Trunk
mozilla0.9.1
x86
Linux
pp, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
i'm using 2001.05.01.08 linux mozilla bits. the monospace font in the source
view of editor is now quite large. however, the fontsize of the monospace font
in a plaintext mail compose --as well as textfields of forms in the browser
window-- is actually of reasonable size [not huge].
(Reporter)

Comment 1

17 years ago
this is a regression.
Keywords: mozilla0.9.1, regression
(Assignee)

Comment 2

17 years ago
I don't see a huge font in my debug build from today, in fact, I don't see
the monospace font in Windows! Is this only on Linux?
Could you please check for size and "monospace" on all platforms. Thanks.
Before the "new" Modern font, the "font-size : larger" I used didn't seem to do
anything (the monospace font was *very* small then.)

Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1

Comment 3

17 years ago
Did you try 'font-family: -moz-fixed'. This seems to give a reasonable default 
because it is tweaked internally (see the settings that viewsource.css uses for 
example). 
(Assignee)

Comment 4

17 years ago
See the fix for bug 76191.
I used this for all platforms.
    font-family   : -moz-fixed, monospace;
    font-size     : larger;
Depends on: 76191
(Assignee)

Comment 5

17 years ago
Hewitt: anything change in new skins checkin that could have caused this?
My recent change for bug 76191 is there; any other "-moz-fixed" not working?
Sarah: Please test all platforms.
Charles, see my comments from "2001-04-30 22:27" on bug 76531.  It seems that at
least on linux -moz-fixed gets ignored in "font-family: -moz-fixed, monospace;"

Removing the "monospace" part makes it work right.

This feels like a bug in the style system, but apparently handling of -moz-fixed
is kinda wacky...
(Assignee)

Comment 7

17 years ago
Not being able to handle "-moz-fixed, monospace" sounds like a real bug to me;
that is standard CSS syntax. Did you file a bug on that issue (Linux-only,
correct)?
Bug 78517 filed.

I don't know whether this is Linux-only.  I don't have anything else to test on
(well, Solaris and Irix, but...)

Easy way to test.  With the "-moz-fixed, monospace" in your stylesheet, pick a
very small font for monospace in preferences.  If the text in question is shown
in the really small font, then things are working correctly.  Otherwise you're
seeing bug 78517.

If people could test that on Windows/Mac and comment on 78517, that would be great.
(Assignee)

Comment 9

17 years ago
Ok, we don't have time to mess around. I'll change the CSS to simply use:
#content-source, #doctype-text {
font-family   : -moz-fixed;
}
Note that I'm dropping the previously-added
font-size     :  larger;
as the user's pref includes setting the size, so this seems the correct thing
to do.

(Assignee)

Comment 10

17 years ago
Created attachment 32887 [details] [diff] [review]
Simplify CSS to just use "font-family : -moz-fixed"
(Assignee)

Updated

17 years ago
Whiteboard: FIX IN HAND need r=, sr=

Comment 12

17 years ago
Charley said in bug 76191 that this bug contained the patch to fix the problem
in that bug (using fixed-width fonts in plaintext compose), but the patch to
this bug does not fix that problem -- I still see variable-width fonts in the
plaintext compose window after applying this patch and rebuilding in mozilla/themes.
(Assignee)

Comment 13

17 years ago
I'm having trouble pulling today, but yesterday (after the "new" modern landing),
I also *didn'* see the fixed width font in Windows. I think something was busted
with new theme :( I believe this patch is the right one, though, to try
to get fixed width.
Hewitt?

Comment 14

17 years ago
Applied and tested the patch on Win2K and it worked as expected.
Before the patch, clicking '<HTML> source' was rendering in a variable-size 
font. After the patch, it renders in a fixed-size font.
(Assignee)

Comment 15

17 years ago
Looks ok on Windows now. What about Mac and Linux?
(Assignee)

Comment 16

17 years ago
Reviews done, just need final testing to mark fixed.
Whiteboard: FIX IN HAND need r=, sr= → FIX IN HAND
Fixes things for me on Linux as well...

Comment 18

17 years ago
In my Linux build from today, I still see a huge font in the html source tab.
(Assignee)

Comment 19

17 years ago
The font size should be whatever is set in your user prefs for
Appearance | Fonts | "Fixed-width fonts". Try adjusting that.
(Assignee)

Comment 20

17 years ago
The font size in the prefs isn't being respected in the multiline textfield
(i.e., HTML Source window), but that's a separate issue. (I will file a new bug.)
Marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 21

17 years ago
Please resolve this bug when the new bug has been filed (I don't see one right 
now); reopening for now
Status: RESOLVED → REOPENED
Keywords: pp
Resolution: FIXED → ---
(Assignee)

Comment 22

17 years ago
Bug 79227 has been filed on the issue that font size is not set correctly.
It seems most correct to dup this bug to that one, since this bug did address
the size issue to begin with.


*** This bug has been marked as a duplicate of 79277 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Whiteboard: FIX IN HAND

Comment 23

17 years ago
verified in 5/7 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.