Kuma: Changing a page slug does not affect its childrens' slugs

RESOLVED DUPLICATE of bug 764431

Status

P1
blocker
RESOLVED DUPLICATE of bug 764431
6 years ago
6 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
If you change the slug of a page, thereby changing its URL, the slugs of the children do not get altered. They should be updated along with their parent. This is causing a lot of confusion (and concern about data loss). We need to correct this right away!
This is the move page feature. What looked like a data loss was actually a display issue.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 764431

Comment 2

6 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/8a3ae0446657c6334ff8d2fac5575b9cae683696
bug 784456 - fix display of parent slug

https://github.com/mozilla/kuma/commit/2c46b911dc4adcfbfbf9298c879c346d11bdd65a
Merge pull request #525 from groovecoder/parent-slug-display-784456

bug 784456 - fix display of parent slug
(Assignee)

Updated

6 years ago
Version: Kuma → unspecified
(Assignee)

Updated

6 years ago
Component: Docs Platform → Editing
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.