Show compatibility error if an add-on uses nsIGlobalHistory

VERIFIED FIXED in 2012-08-23

Status

addons.mozilla.org Graveyard
Compatibility Tools
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: jorgev, Assigned: basta)

Tracking

unspecified
2012-08-23

Details

(Whiteboard: [fx15])

(Reporter)

Description

5 years ago
As explained in bug 615213, the nsIGlobalHistory interface has been removed. We need to flag all instances of this interface and show an error.

This is a compatibility error, so the add-on should not be upgraded in this case.

Message:

The nsIGlobalHistory interface has been removed. You can use nsIGlobalHistory2 instead. See <LINK> for more information.

Link: https://bugzilla.mozilla.org/show_bug.cgi?id=615213

Affected add-on:

https://addons.mozilla.org/en-US/firefox/addon/chatzilla/

I'm setting the milestone for the 23rd because the final release is scheduled for the 28th. I understand if we can't make it for the 23rd, but it'd be great to do the bump before the release date.
(Assignee)

Comment 1

5 years ago
Merged:

https://github.com/mozilla/amo-validator/commit/3f6231502aa357ca1657857135abd39bc1d45c2e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 2

5 years ago
verified fixed at https://addons-dev.allizom.org/en-US/developers/upload/3e837bae9dc64c8393a872d7fa98cc4e
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.