Show compatibility error if an add-on uses mozIStorageStatementWrapper

VERIFIED FIXED in 2012-08-23

Status

addons.mozilla.org Graveyard
Compatibility Tools
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: jorgev, Assigned: basta)

Tracking

unspecified
2012-08-23

Details

(Whiteboard: [fx15])

(Reporter)

Description

6 years ago
As explained in bug 589032, the mozIStorageStatementWrapper interface has been removed. We need to flag all instances of this interface and show an error.

This is a compatibility error, so the add-on should not be upgraded in this case.

Message:

The mozIStorageStatementWrapper interface has been removed. It is no longer necessary, you can use mozIStorageStatement directly instead. See <LINK> for more information.

Link: https://blog.mozilla.org/nfroyd/2012/05/14/statement-wrappers-have-been-deprecated/

Affected add-on:

TBD (the add-ons MXR is down)
(Assignee)

Comment 1

6 years ago
Merged:

https://github.com/mozilla/amo-validator/commit/3f6231502aa357ca1657857135abd39bc1d45c2e
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 2

6 years ago
verified fixed at https://addons-dev.allizom.org/en-US/developers/upload/a6f0fb5f4e67428ab4dc765c1da8401f
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.