Last Comment Bug 784536 - Birch OS X gcc builds broken by bug 784004 ("content/media/nsBuiltinDecoderReader.cpp:226: error: 'mozilla::ImageFormat' is not a class or namespace")
: Birch OS X gcc builds broken by bug 784004 ("content/media/nsBuiltinDecoderRe...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- critical (vote)
: mozilla17
Assigned To: :Ehsan Akhgari (out sick)
:
Mentors:
: 784452 (view as bug list)
Depends on:
Blocks: 784004
  Show dependency treegraph
 
Reported: 2012-08-21 15:38 PDT by Ed Morley [:emorley]
Modified: 2012-08-22 02:45 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (1.05 KB, patch)
2012-08-21 15:49 PDT, :Ehsan Akhgari (out sick)
dzbarsky: review+
Details | Diff | Review

Description Ed Morley [:emorley] 2012-08-21 15:38:32 PDT
OS X 10.7 64-bit birch leak test build on 2012-08-21 10:02:58 PDT for push bb600df09179

slave: bld-lion-r5-044

Failure:

{
../../../content/media/nsBuiltinDecoderReader.cpp: In member function 'virtual void* nsBuiltinDecoderReader::VideoQueueMemoryFunctor::operator()(void*)':
../../../content/media/nsBuiltinDecoderReader.cpp:226: error: 'mozilla::ImageFormat' is not a class or namespace
}

Pushlog:
https://tbpl.mozilla.org/php/getParsedLog.php?id=14566480&tree=Birch

Last bug to touch file:
Bug 784004

Diff:
https://hg.mozilla.org/projects/birch/diff/3000e30d082c/content/media/nsBuiltinDecoderReader.cpp
Comment 1 :Ehsan Akhgari (out sick) 2012-08-21 15:49:44 PDT
Created attachment 653990 [details] [diff] [review]
Patch (v1)
Comment 2 :Ehsan Akhgari (out sick) 2012-08-21 16:08:28 PDT
*** Bug 784452 has been marked as a duplicate of this bug. ***
Comment 3 :Ehsan Akhgari (out sick) 2012-08-21 16:08:42 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/56cec1a9c52a
Comment 5 Ed Morley [:emorley] 2012-08-22 02:45:30 PDT
https://hg.mozilla.org/mozilla-central/rev/56cec1a9c52a

Note You need to log in before you can comment on or make changes to this bug.