Video upload issues

VERIFIED FIXED in 2012-08-23

Status

Marketplace
Developer Pages
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: andym)

Tracking

({regression})

2012-08-23
regression
Points:
---

Details

(URL)

(Reporter)

Description

5 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/developers/app/test-app-cow878/edit
2. Notice the loading image for screenshots and videos

observed behavior:
Video uploads have been sketchy and never complete. Headers show a lot of 404.
[14:56:54.344] GET https://marketplace-dev-cdn.allizom.org/img/uploads/previews/thumbs/76/76361.png?modified=1345583898&1345586214288 [HTTP/1.1 404 Not Found 21ms] 

Jason looked into the logs, and we are seeing theses errors: 

Errors in the log:
Aug 21 14:18:18 celery1.dev.addons.phx1.mozilla.com: [][] z.devhub.task:INFO [1@None] Encoding video 76361 :/data/www/addons-dev.allizom.org/zamboni/lib/video/tasks.py:26
Aug 21 14:18:18 celery1.dev.addons.phx1.mozilla.com: [][] z.video:INFO totem called with: totem-video-indexer /mnt/netapp_amo_dev/addons-dev.allizom.org/shared_storage/tmp/preview/01a69e4ea13f4afa94176ca290d0884f.video-webm :/data/www/addons-dev.allizom.org/zamboni/lib/video/totem.py:31
Aug 21 14:18:18 celery1.dev.addons.phx1.mozilla.com: [][] celery:INFO Task addons.tasks.index_addons[a3b1f34d-f476-4fbe-b0e7-b6e7373bda4e] succeeded in 0.285171031952s: None :/data/www/addons-dev.allizom.org/zamboni/vendor/lib/python/celery/worker/job.py:332
Aug 21 14:18:18 celery2.dev.addons.phx1.mozilla.com: [][] celery:INFO Task addons.tasks.index_addons[b4289489-b865-414a-a3b6-d63e432c3c47] succeeded in 0.166167974472s: None :/data/www/addons-dev.allizom.org/zamboni/vendor/lib/python/celery/worker/job.py:332
Aug 21 14:18:18 celery1.dev.addons.phx1.mozilla.com: [][] z.video:INFO totem returned: GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Not running within active session)#012GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Not running within active session)#012GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Not running within active session)#012TOTEM_INFO_DURATION=84#012TOTEM_INFO_HAS_VIDEO=True#012TOTEM_INFO_VIDEO_WIDTH=640#012TOTEM_INFO_VIDEO_HEIGHT=360#012TOTEM_INFO_VIDEO_CODEC=VP8 video#012TOTEM_INFO_FPS=25#012TOTEM_INFO_HAS_AUDIO=True#012TOTEM_INFO_AUDIO_BITRATE=160#012TOTEM_INFO_AUDIO_CODEC=Vorbis#012TOTEM_INFO_AUDIO_SAMPLE_RATE=44100#012TOTEM_INFO_AUDIO_CHANNELS=Stereo#012 :/data/www/addons-dev.allizom.org/zamboni/lib/video/totem.py:37
Aug 21 14:18:18 celery1.dev.addons.phx1.mozilla.com: [][] z.devhub.task:INFO Error encoding video for 76361, {'duration': '84', 'formats': 'VP8'} :/data/www/addons-dev.allizom.org/zamboni/lib/video/tasks.py:44#012Traceback (most recent call last):#012  File "/data/www/addons-dev.allizom.org/zamboni/lib/video/tasks.py", line 41, in resize_video#012    video_file = video.get_encoded(amo.ADDON_PREVIEW_SIZES[1])#012TypeError: get_encoded() takes exactly 1 argument (2 given)
Aug 21 14:18:18 celery1.dev.addons.phx1.mozilla.com: [][] celery:INFO Task lib.video.tasks.resize_video[f9ae55d8-ae99-48bd-be56-2388489b532c] succeeded in 0.366291046143s: None :/data/www/addons-dev.allizom.org/zamboni/vendor/lib/python/celery/worker/job.py:332


These errors started showing up on 08/14. So, i am marking this as a regression.
(Assignee)

Comment 1

5 years ago
I fixed the "get_encoded() takes exactly 1 argument (2 given)" error, but that's just masking the real error.
Assignee: nobody → amckay
(Assignee)

Comment 2

5 years ago
The video-encode switch was on. It shouldn't be until we get ffmpeg licensed/installed on webheads. Just the video-upload switch should be on.

https://github.com/mozilla/zamboni/commit/231bee
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 3

5 years ago
Verified as fixed. Videos uploaded without any problem : http://screencast.com/t/jVCOSDvv
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.