Closed Bug 784570 Opened 9 years ago Closed 9 years ago

window size is weird after starting thunderbird when previously maximized

Categories

(Thunderbird :: General, defect)

17 Branch
x86_64
Windows 7
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 783899

People

(Reporter: jebrosen2014, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120821092158

Steps to reproduce:

(Thunderbird Daily 17.0a1 2012-08-21)
1. Maximize Daily's main window (only window open)
2. Completely exit Daily (close main window)
3. Start Daily again


Actual results:

Daily opened in a partially maximized state: All sides of the window were correct (flush against the sides of the screen, no border) except the bottom, which was a few pixels from the bottom edge of the screen. Pressing the restore/maximize button restored the window to floating as if it had already been maximized. Pressing maximize after that maximized it properly at that point.


Expected results:

Daily should have opened in a fully maximized state as it was in when closed.

NOTE: I currently have the taskbar on the left side of the screen. I moved it to the bottom to test and the same issue was present.
Severity: normal → minor
Hardware: x86 → x86_64
Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/86ee4deea55b
http://hg.mozilla.org/comm-central/rev/ca6d6339aee9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Thunderbird/17.0a1 ID:20120815030207
Bad:
http://hg.mozilla.org/mozilla-central/rev/50e4ff05741e
http://hg.mozilla.org/comm-central/rev/c2e7f36be6b4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Thunderbird/17.0a1 ID:20120816030547
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=86ee4deea55b&tochange=50e4ff05741e
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=ca6d6339aee9&tochange=c2e7f36be6b4
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 783899
You need to log in before you can comment on or make changes to this bug.