No onchange event after seleted options by value selector(mozbrowser <select>)

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: iliu@mozilla.com, ianliu.moz@gmail.com, Assigned: schien)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

STR
====

1. Launch Clock app or UI Test app with B2G Desktop build or on B2G device.
2.
  A) Clock app: 
     a) Click right-top corner button to create an alarm.
     b) Click repeat, sound, snooze menu to select options.
     c) The value selector overlay will show up.
     d) Select one of the options and click [OK]

  B) UI Test app:
     a) Listen the onchange event of the any <select> first.
     b) Click the <select>, the value selector overlay will show up
     c) Select one of the options and click [OK]

Actual result:
 - There is no onchange event after seleted options and confirmed it by value selector.

Expected result:
 - "onchange" event should be fired after seleted options and confirmed it by value selector.

Note:
  There is no way to update the result of selection.
Vivien, is that because of how the vkb is implemented or is that a bug with the DOM implementation?
Is this a dup of bug 781438?
In b2g/chrome/content/forms.js, the selected option is changed via javascript, which will not generate onchange event. We need to create a onchange event mannually.
Assignee: nobody → schien
Created attachment 657528 [details] [diff] [review]
bug784590 - need manually fire onchange event if any selected option is change, v1

Onchange event is not fired due to selected option is changed via javascript in b2g/chrome/content/forms.js. We need to manually create a DOMEvent and fire it on <select> element.
Attachment #657528 - Flags: review?(fabrice)
Attachment #657528 - Flags: review?(fabrice) → review+

Updated

6 years ago
Whiteboard: [qa-]
https://hg.mozilla.org/mozilla-central/rev/6300a954d434
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.