Page pegs CPU at near-100%

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: bischoff, Assigned: attinasi)

Tracking

({perf, testcase})

Trunk
x86
Windows 2000
perf, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:20011126], URL)

Attachments

(1 attachment)

5.25 KB, application/octet-stream
Details
(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.8.1+)
Gecko/20010501
BuildID:    2001050104

Loading this page causes Mozilla to peg at near-100%.

Reproducible: Always
Steps to Reproduce:
1. Load Task Manager, goto Processes tab
2. Load the url in Mozilla
3. Look at Task Manager -- see that Mozilla is near-100%

Actual Results:  Mozilla uses near-100% of CPU.

Expected Results:  Mozilla should behave :).

This is on Win2k SP1, with Modern skin.
(Reporter)

Comment 1

18 years ago
Adding perf keyword.
Keywords: perf

Comment 2

18 years ago
Created attachment 32860 [details]
Testcase (Zipped)

Comment 3

18 years ago
I've tried to make the testcase slim but cannot because it's the hugh amount of 
text that's causing the problems.

When you remove the <UL> </UL> tags the file can be loaded without hanging.

I guess the author of this page tries to achieve paragraph indentation using 
<UL> tags, but there is no <LI> tags within the <UL> </UL> nest.  Another 
example of bad/misused HTML coding.
(Reporter)

Comment 4

18 years ago
DoctorJ: It could very well be a case of bad/misused HTML coding (I didn't write
the page). Nevertheless, I'd like to think that Mozilla wouldn't peg the CPU
under any circumstance ;).

Updated

18 years ago
Keywords: testcase
confirming with win2k build 20010512.. (CVS)
mozilla shouldn´t use 100% cpu on my Athlon900
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
testcase URL no longer valid (?) -- just a simple http file listing

Comment 7

17 years ago
no testcase, but the report mention no problems with tables, only un-ordered 
lists.  reassigning to core owner.
Assignee: karnaze → attinasi
Whiteboard: [NEED TESTCASE]

Comment 8

17 years ago
the attached test case that ------- Additional Comment #2 From 
doctor__j@hotmail.com 2001-05-02 00:57 ------- added renders just fine in the 
build from 20011126 on win98.

Marking as WFM
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Whiteboard: [NEED TESTCASE] → [bae:20011126]
You need to log in before you can comment on or make changes to this bug.