Message list: Can't get choice of columns to persist: "From" for inbox-type folders and "Recipient" for Sent-type folders

RESOLVED DUPLICATE of bug 710056

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 710056
6 years ago
5 years ago

People

(Reporter: Hillel Markowitz, Unassigned)

Tracking

14 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme?)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120814224555

Steps to reproduce:

I changed the message pane header line to show "Sender" in Inbox and remove "Recipient". This was successful. However when I exited Thunderbird and later brought it up, the "Recipient" header was back and the "Sender" header was no longer active.


Actual results:

When I exited Thunderbird and later brought it up, the "Recipient" header was back and the "Sender" header was no longer active.


Expected results:

The "Sender" header should have stayed active and the "Recipient" header should not have reappeared.

Comment 1

6 years ago
Hillel, are you referring to the column headers of the message list?

Message pane is where the message preview is shown, and message pane headers are From, Subject, To headers for the currently viewed message, to the left of the message reply buttons etc.
Whiteboard: wrong summary?
(Reporter)

Comment 2

6 years ago
Yes that is what I mean. Inbox shows "Recipient" even though I change it to show "From". There are times when it stays as I set it, but then later when I bring it up will show "Recipient". What I want to do is have INBOX (and similar folders) show "From" and Sent show "Recipient". It is annoying to have to keep changing it by hand.

I have the three pane window. On the left is the list of folders. The top pane is the list of messages. The header on that pane, in order to determine what message fields to show is what I mean.

Comment 3

6 years ago
Hillel, thanks for quick feedback. I've adjusted your summary accordingly.
It touches two problems:
1) general persistence of picked columns (I think we recently fixed that)
2) automatic alternation between "from" for inbox-type folders and "recipient" for sent-type of folders (not sure about the status of that one, I remember a bug for that, too)
Summary: Message Pane Header cannot be customized → Message list: Can't get choice of columns to persist: "From" for inbox-type folders and "Recipient" for Sent-type folders
Whiteboard: wrong summary? → dupme?
(Reporter)

Comment 4

6 years ago
OK thanks. I will expect to see the fixes as updates come in.
(Reporter)

Comment 5

6 years ago
(In reply to Thomas D. from comment #3)
> Hillel, thanks for quick feedback. I've adjusted your summary accordingly.
> It touches two problems:
> 1) general persistence of picked columns (I think we recently fixed that)
> 2) automatic alternation between "from" for inbox-type folders and
> "recipient" for sent-type of folders (not sure about the status of that one,
> I remember a bug for that, too)

The latest update from Thunderbird 15.0 still has the problem

Comment 6

6 years ago
Thunderbird 15.0.1 still has the following problem with persistence of picked columns:  inbox and/or sent columns change after compacting folders.

In the Inbox, I want only subject, from, and date.  In Sent, I want only subject, recipient, and date.  After I compact the folders, I may additionally get thread, attachments, starred, read, and junk status columns.  And, since it takes two clicks of the mouse to get rid of each of these columns, it is very annoying.
(Reporter)

Comment 7

6 years ago
The problem shows up even when I do not compact the folders.

Comment 8

6 years ago
I'm also seeing this problem (columns for pop3 inbox are not persisted) all the time throughout recent versions including current TB15 on WinXP, and find it highly annyoing.

Comment 9

6 years ago
This is probably bug 710056. That landed today for TB 18, but will probably be pushed to TB 17 eventually.
(In reply to Kent James (:rkent) from comment #9)
> This is probably bug 710056. That landed today for TB 18, but will probably
> be pushed to TB 17 eventually.

That happenned can you guys see if the beta still has the issue ?

Comment 11

5 years ago
TB 16 in Fedora 17 seems to have fixed the problem.

Comment 12

5 years ago
I looked at the list of bugs fixed for TB16, and it included 710056.  That fix has solved the problem I had, which was changing of columns when I emptied trash and then compacted folders.

So, thank-you.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 710056
(Reporter)

Comment 14

5 years ago
I am running TB 16.02 and the problem seems to have come back. It appears to be erratic though. Some folders show the problem and some do not. It does not appear consistently in the Inbox of the different accounts.
(Reporter)

Comment 15

5 years ago
Still occuring in Thunderbird 19 Beta 1
You need to log in before you can comment on or make changes to this bug.