pressing the delete key removes elements from the page

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: cobexer, Unassigned)

Tracking

14 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120814224555

Steps to reproduce:

go to http://jqueryui.com/demos/draggable/default.html and click on the box, then without doing anything else press the delete key (multiple times)

Firefox 14.0.1 and Firefox 15.0 both reproduce this issue.

i was unable to find out what removed the elements (since DOM mutation events seem to be useless) and can't reproduce this issue in other browsers(Chrome 22, IE9)


Actual results:

parts of the page will now vanish


Expected results:

nothing

Comment 1

6 years ago
Do you have any extensions installed?

Comment 2

6 years ago
You'll probably find it's caused by NoScript, if you have that installed. It's a new 'feature' that was just added.
(Reporter)

Comment 3

6 years ago
(In reply to mjh563 from comment #2)
> You'll probably find it's caused by NoScript, if you have that installed.
> It's a new 'feature' that was just added.

yes i do have NoScript installed

do you have a link to the feature tracker of NoScript that documents the removal process of that "feature"?
(Reporter)

Comment 4

6 years ago
disabling NoScript fixed the issue, I'm still interested in the "NoScript feature tracker link" tough :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.