background repeat gets out of step after many repeats

RESOLVED DUPLICATE of bug 671302

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 671302
5 years ago
5 years ago

People

(Reporter: martien friedeman, Unassigned)

Tracking

14 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 654408 [details]
zipped the large HTML file and the background image

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 2012071300

Steps to reproduce:

Create a large HTML page with more 1000 lines.
On each line, display a sequential number.

Display a background on that page.
Use a repeat image for that background.
Make the repeat image repeat itself on every line. 

The whole thing should give an impression of printed numbers on lined stationary.



Actual results:

All is well for the first 800-900 lines:
Each number appears nicely above its background. 

After line 900 there is a hiccup. Suddenly the repeat is out of step.
The background does not align anymore.


Expected results:

The background should align all over the page.
Once the background is out of step, the remainder of the page is ruined.
(Reporter)

Comment 1

5 years ago
Created attachment 654428 [details]
screenshot of HTML page
(Reporter)

Comment 2

5 years ago
I noticed while creating a snapshot of the page that removing the focus and giving it the focus again redraws the page correctly.
That redrawn page has the foreground and background aligned.

However, that alignment disappears again as soon as I scroll down just one page.

Comment 3

5 years ago
Surely a dupe of bug 671302.

Comment 4

5 years ago
(In reply to Loic from comment #3)
> Surely a dupe of bug 671302.

Marking then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671302
You need to log in before you can comment on or make changes to this bug.