Database error when running a query

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Ehsan, Assigned: scabral)

Tracking

Details

(Reporter)

Description

6 years ago
I got the following error when loading <https://bugzilla.mozilla.org/buglist.cgi?quicksearch=make%20windows%20timestamps%20faster;list_id=4142710>:

DBD::mysql::st execute failed: Lost connection to MySQL server during query [for Statement "SELECT bugs.bug_id AS bug_id, bugs.bug_severity AS bug_severity, bugs.priority AS priority, bugs.bug_status AS bug_status, bugs.resolution AS resolution, map_products.name AS product, bugs.op_sys AS op_sys, map_assigned_to.login_name AS assigned_to, bugs.short_desc AS short_desc FROM bugs INNER JOIN profiles AS map_assigned_to ON (bugs.assigned_to = map_assigned_to.userid) INNER JOIN products AS map_products ON (bugs.product_id = map_products.id) LEFT JOIN bugs_fulltext AS bugs_fulltext_0 ON (bugs.bug_id = bugs_fulltext_0.bug_id) LEFT JOIN bugs_fulltext AS bugs_fulltext_1 ON (bugs.bug_id = bugs_fulltext_1.bug_id) LEFT JOIN bugs_fulltext AS bugs_fulltext_2 ON (bugs.bug_id = bugs_fulltext_2.bug_id) LEFT JOIN bugs_fulltext AS bugs_fulltext_3 ON (bugs.bug_id = bugs_fulltext_3.bug_id) LEFT JOIN bug_status ON (bug_status.value = bugs.bug_status) LEFT JOIN priority ON (priority.value = bugs.priority) LEFT JOIN bug_group_map ON bug_group_map.bug_id = bugs.bug_id AND bug_group_map.group_id NOT IN (20,19,10,9,94,23,2,69,84,98,32,6,42,26,33,29,96,47) LEFT JOIN cc ON cc.bug_id = bugs.bug_id AND cc.who = 251051 WHERE (( bugs.bug_status IN ('REOPENED','NEW','ASSIGNED','UNCONFIRMED') )) AND ((( bugs.product_id IN (89) ) OR ( bugs.component_id IN (1456) ) OR (INSTR(COALESCE(bugs.alias, ''), 'make') > 0) OR (INSTR(bugs.short_desc, 'make') > 0) OR (INSTR(bugs.status_whiteboard, 'make') > 0) OR (MATCH(bugs_fulltext_0.comments) AGAINST('\"make\"' IN BOOLEAN MODE) OR MATCH(bugs_fulltext_0.short_desc) AGAINST('\"make\"' IN BOOLEAN MODE)) OR (INSTR(bugs.cf_crash_signature, 'make') > 0))) AND (((1=2) OR ( bugs.component_id IN (82,963,964) ) OR (INSTR(COALESCE(bugs.alias, ''), 'windows') > 0) OR (INSTR(bugs.short_desc, 'windows') > 0) OR (INSTR(bugs.status_whiteboard, 'windows') > 0) OR (MATCH(bugs_fulltext_1.comments) AGAINST('\"windows\"' IN BOOLEAN MODE) OR MATCH(bugs_fulltext_1.short_desc) AGAINST('\"windows\"' IN BOOLEAN MODE)) OR (INSTR(bugs.cf_crash_signature, 'windows') > 0))) AND (((1=2) OR (1=2) OR (INSTR(COALESCE(bugs.alias, ''), 'timestamps') > 0) OR (INSTR(bugs.short_desc, 'timestamps') > 0) OR (INSTR(bugs.status_whiteboard, 'timestamps') > 0) OR (MATCH(bugs_fulltext_2.comments) AGAINST('\"timestamps\"' IN BOOLEAN MODE) OR MATCH(bugs_fulltext_2.short_desc) AGAINST('\"timestamps\"' IN BOOLEAN MODE)) OR (INSTR(bugs.cf_crash_signature, 'timestamps') > 0))) AND (((1=2) OR ( bugs.component_id IN (1308) ) OR (INSTR(COALESCE(bugs.alias, ''), 'faster') > 0) OR (INSTR(bugs.short_desc, 'faster') > 0) OR (INSTR(bugs.status_whiteboard, 'faster') > 0) OR (MATCH(bugs_fulltext_3.comments) AGAINST('\"faster\"' IN BOOLEAN MODE) OR MATCH(bugs_fulltext_3.short_desc) AGAINST('\"faster\"' IN BOOLEAN MODE)) OR (INSTR(bugs.cf_crash_signature, 'faster') > 0))) AND bugs.creation_ts IS NOT NULL AND ((bug_group_map.group_id IS NULL) OR (bugs.reporter_accessible = 1 AND bugs.reporter = 251051) OR (bugs.cclist_accessible = 1 AND cc.who IS NOT NULL) OR (bugs.assigned_to = 251051) OR (bugs.qa_contact = 251051) ) GROUP BY bugs.bug_id ORDER BY bug_status.sortkey,bug_status.value,priority.sortkey,priority.value,assigned_to,bug_id LIMIT 10001"]
works for me; over to the DBAs to see if they can shed any light on it.
Assignee: nobody → server-ops-database
Component: General → Server Operations: Database
Product: bugzilla.mozilla.org → mozilla.org
QA Contact: cshields
Version: Production → other
(Assignee)

Comment 2

6 years ago
The page works for me, it does take a long time, so it's possible that there was a limit hit that caused the query to time out...that for some reason we can't reproduce. I'll look and see if there were any errors or warnings at that point in time.
(Assignee)

Comment 3

6 years ago
There are no database errors during that time. Ehsan, have you been able to reproduce the error at all?
(Reporter)

Comment 4

6 years ago
(In reply to comment #3)
> There are no database errors during that time. Ehsan, have you been able to
> reproduce the error at all?

No.
(Assignee)

Comment 5

6 years ago
Marking as resolved/worksforme then. If it happens again, please do re-open this bug or open a new one.
Assignee: server-ops-database → scabral
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Product: mozilla.org → Data & BI Services Team
You need to log in before you can comment on or make changes to this bug.