Last Comment Bug 785173 - LinkedIn URL displays some form of auto-refresh that prevents site navigation
: LinkedIn URL displays some form of auto-refresh that prevents site navigation
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 15 Branch
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 11:50 PDT by Christopher Arnold
Modified: 2012-08-27 14:31 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of LinkedIn blank "redirecting" message (198.66 KB, image/png)
2012-08-23 11:50 PDT, Christopher Arnold
no flags Details
Safe Mode startup of LinkedIn still experiences URL error (321.75 KB, image/png)
2012-08-23 12:16 PDT, Christopher Arnold
no flags Details
LinkedIn throws the attached error if the user doesn't close the tab (280.41 KB, image/png)
2012-08-23 12:18 PDT, Christopher Arnold
no flags Details
Nightly can also replicate the bug (428.55 KB, image/png)
2012-08-23 12:23 PDT, Christopher Arnold
no flags Details

Description Christopher Arnold 2012-08-23 11:50:20 PDT
Created attachment 654717 [details]
Screenshot of LinkedIn blank "redirecting" message

LinkedIn is behaving strangely on my Firefox and Nightly.  Main site loads.  But if the user clicks on any of the nav elements at the top of the page, the URL starts to do some kind of automated refresh.  The screen goes blank in a "Redirecting" message and the tab flashes repeatedly as attempts to load the URL fail.

For instance, this URL can't load: https://www.linkedin.com/jobs?trk=hb_tab_jobs_top&displayHome=

It happens across all some LinkedIn navigation elements.  But not all of them.  It continues happening even when I disable add-ons.

The error does not happen in Safari.
Comment 1 Dão Gottwald [:dao] 2012-08-23 11:56:31 PDT
Can you reproduce this in safe mode?

Your screenshot appears to show Firefox 13 or older, by the way.
Comment 2 Christopher Arnold 2012-08-23 12:16:42 PDT
Created attachment 654730 [details]
Safe Mode startup of LinkedIn still experiences URL error

After restarting in safe mode it does appear to still be happening.
Comment 3 Christopher Arnold 2012-08-23 12:18:36 PDT
Created attachment 654732 [details]
LinkedIn throws the attached error if the user doesn't close the tab
Comment 4 Christopher Arnold 2012-08-23 12:23:11 PDT
Created attachment 654734 [details]
Nightly can also replicate the bug
Comment 5 Christopher Arnold 2012-08-27 09:03:51 PDT
The bug may be caused by a tracking URL that Linkedin cycles into the redirect, which fails, causing the redirect to launch.  The failed redirect causes a recurring loop to flash between the following two URLs.

https://www.linkedin.com/mbox?trk=COMM_NI&displayMBoxItem=&itemID=I413479474_9
https://www.linkedin.com/mbox?itemID=I413479474_9&displayMBoxItem=&trk=COMM_NI

Is there anything that we know in Firefox privacy settings that prevent tracking URLs from being established by a site?

When I try to access exactly the same links I attempted to load in Firefox, but use Safari instead, the following URL string is generated as I'm redirected successfully.
http://www.linkedin.com/mbox?displayMBoxItem=&itemID=I413479474_9&goback=%2Efps_PBCK_*1_*1_*1_*1_*1_*1_*1_*2_*1_Y_*1_*1_*1_false_1_DR_*1_*51_*1_*51_true_*1_*2_*2_*2_F+S_*2_157247_*2_*2_*2_*2_*2_*2_*2_*2_*2_*2_*2_*2_*2_*2&trk=COMM_NI

Is there a possibility that LinkedIn did something tricky in their user tracking that is causing more widespread failures to load?  Or is this likely a single user issue?
Comment 6 Christopher Arnold 2012-08-27 14:31:55 PDT
Anurag found that this error is caused by certain LinkedIn cookies.  Perhaps because the user here was using both Firefox and Nightly.

Note You need to log in before you can comment on or make changes to this bug.