WebGL Zygote Body looks diseased in Firefox Android

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
4 months ago

People

(Reporter: callow.mark, Assigned: jgilbert)

Tracking

(Blocks 1 bug)

17 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [games:p?] webgl-driver, )

Attachments

(1 attachment)

Reporter

Description

7 years ago
Visit www.zygotebody.com in Firefox Android. Note the diseased appearance on the skin of the arms, hands and legs of the female figure. The arms and hands are particularly bad.

There are other issues too:
- on PC drag with left mouse down rotates the figure. On Android dragging just shifts the whole window.
- on PC drag the slider on the left moves from skin deeper into the body. ON Android same effect as trying to rotate the figure.
- If you switch from the female to the male figure (click the man-women icon at the top of the left-side stack) both male and female are drawn interleaved.

I'm using 17a01, 2012-08-23 on Android 4.0.3 on a Xoom/Tegra 2.
Reporter

Comment 1

7 years ago
There is one other weirdness. When FF Android begins loading this URL a dialog box appears saying that the page uses plug-in content and asking if it is OK to run it. Even if I do nothing, the page seems to load OK and, as far as I know, there is no plug-in content on the page.
Whiteboard: [games:p2]
QA, can you check this URL on various devices with currently Nightly Firefox for Android?  There have been a lot of graphics stack changes that I suspect that this is fixed.
Keywords: qawanted
Assignee

Comment 3

6 years ago
I can reproduce something like this on a Galaxy Tab 10.1 (Tegra 2) and a Nexus 7 (Tegra 3).
This does not reproduce on a Nexus 4 (Adreno 320) or Nexus 10 (Mali-T604).

It looks like bad z-buffering. I'll attach a screenshot of what I see.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 5

6 years ago
Chrome doesn't render anything on the Galaxy Tab 10.1 or Nexus 7.
It renders fine in Chrome on Nexus 4, but is blocked from using WebGL on Nexus 10.
Assignee

Comment 6

6 years ago
I think this is probably due to receiving a 16-bit depth buffer, instead of 24-bit or higher elsewhere.
Testing this should just require testing using explicitly-16-bit depth buffers, which should be easy enough to hack together.
Assignee

Updated

6 years ago
Assignee: nobody → jgilbert
Flags: needinfo?(jgilbert)
Keywords: qawanted
Whiteboard: [games:p2] → [games:p2] webgl-driver
Assignee

Comment 7

5 years ago
I can still reproduce this, but the driver on the Nexus 7 doesn't support >16bit depth buffers, except via d24_s8, probably.
Flags: needinfo?(jgilbert)
Assignee

Comment 8

5 years ago
Actually, neither tegra device supports >16bit depth buffers at all, at least in GLES2. (Which I'm fairly sure the Tegra3 is limited to)

I'll have to try limiting a currently-functional device to 16bit depth and check if it repros.
Whiteboard: [games:p2] webgl-driver → [games:p?] webgl-driver
Assignee

Comment 9

4 months ago

Please reopen if you're still seeing this!

Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.