promise/core.js fails test against hostile promises

RESOLVED DUPLICATE of bug 881047

Status

Add-on SDK
General
P2
normal
RESOLVED DUPLICATE of bug 881047
5 years ago
4 years ago

People

(Reporter: Yoric, Assigned: jsantell)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 654750 [details] [diff] [review]
Testing a hostile promise against promise/core.js

This bug is rather surprising, as I seem to remember that promise.js (from the addon-sdk on github) succesfully rejected hostile promises.

Irakli, could you take a look and tell me if I got something wrong somewhere?
Attachment #654750 - Flags: feedback?(rFobic)
That's surprising indeed, I'll incorporate your tests into our test suite and will submit fix if there is a issue.
Assignee: nobody → rFobic

Updated

5 years ago
Priority: -- → P2
Could you reproduce the issue?
This can probably be closed once bug 881047 is finished and we use Promise.jsm as the backend for our promises.
Depends on: 881047
Can you please include test from the submitted patch to either `Promise.jsm` tests or to our tests to make sure it fixed ?
Assignee: rFobic → jsantell
Attachment #654750 - Flags: feedback?(rFobic)
With Bug 881047 migrating sdk/core/promise to use Promise.jsm as the back end, I think this bug is redundant once that lands.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881047
You need to log in before you can comment on or make changes to this bug.