Featured apps should show up if no time range specified

VERIFIED FIXED in 2012-08-30

Status

Marketplace
Consumer Pages
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: krupa, Assigned: ashort)

Tracking

({regression})

2012-08-30
regression
Points:
---

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 654810 [details]
screenshot

steps to reproduce:
1. Have country = Brazil and load https://marketplace-dev.allizom.org/
2. Notice that there are no featured apps.

expected behavior:
If there are no region-specific featured apps, we show apps featured for Worldwide

observed behavior:
We don't show any featured apps. See screenshot
This is unrelated to regional features/fallbacks. This is a regression from https://github.com/mozilla/zamboni/commit/44000f6c#L4R413

Worldwide: http://f.cl.ly/items/150w0A1H432I31412S2t/Screen%20shot%202012-08-29%20at%208.45.33%20AM.png
United States: http://f.cl.ly/items/1s0C2n0S1f1e1v44470F/Screen%20shot%202012-08-29%20at%208.45.20%20AM.png

We're now always (incorrectly) requiring a time range to be specified for each feature. We should instead just respect a time range if one is specified, otherwise show features indefinitely.
Assignee: nobody → ashort
Keywords: regression
Summary: Backfill from Worldwide when a region has no featured apps → Featured apps should show up if no time range specified
Target Milestone: --- → 2012-08-30
(Assignee)

Comment 2

6 years ago
http://github.com/mozilla/zamboni/commit/79367f0
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

6 years ago
featured apps are still not showing up
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to krupa raj 82[:krupa] from comment #3)
> featured apps are still not showing up

Well, that's because every app that is featured has a time range that has expired: http://cl.ly/image/2Q101s0V0I2X

But on a very related note, removing a start date or end date also not work.
(Assignee)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Comment 6

6 years ago
Verified as fixed.
Screencast for country=Brazil : http://screencast.com/t/gebdPtGoRwb
Status: RESOLVED → VERIFIED

Comment 7

6 years ago
Verified as fixed.
Screencast for country=Brazil : http://screencast.com/t/gebdPtGoRwb
You need to log in before you can comment on or make changes to this bug.